aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
commit6ffc241131436ea399f2afe5d144c4f5eed79f49 (patch)
treeb842888957a92e8af753d25b456fb0060e3880a8 /target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch
parent1e1f3be69922a72a8cb37ed0b1d93f30c638fe3f (diff)
downloadmaster-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.tar.gz
master-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.tar.bz2
master-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.zip
refresh generic 2.6.23 patches in upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11366 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch28
1 files changed, 10 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch b/target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch
index 3a9fe4306d..6a737926af 100644
--- a/target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/200-sched_esfq.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/include/linux/pkt_sched.h
-===================================================================
---- linux-2.6.23.17.orig/include/linux/pkt_sched.h
-+++ linux-2.6.23.17/include/linux/pkt_sched.h
-@@ -155,8 +155,37 @@ struct tc_sfq_qopt
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
+@@ -155,8 +155,37 @@
*
* The only reason for this is efficiency, it is possible
* to change these parameters in compile time.
@@ -40,11 +38,9 @@ Index: linux-2.6.23.17/include/linux/pkt_sched.h
/* RED section */
enum
-Index: linux-2.6.23.17/net/sched/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/net/sched/Kconfig
-+++ linux-2.6.23.17/net/sched/Kconfig
-@@ -144,6 +144,37 @@ config NET_SCH_SFQ
+--- a/net/sched/Kconfig
++++ b/net/sched/Kconfig
+@@ -144,6 +144,37 @@
To compile this code as a module, choose M here: the
module will be called sch_sfq.
@@ -82,11 +78,9 @@ Index: linux-2.6.23.17/net/sched/Kconfig
config NET_SCH_TEQL
tristate "True Link Equalizer (TEQL)"
---help---
-Index: linux-2.6.23.17/net/sched/Makefile
-===================================================================
---- linux-2.6.23.17.orig/net/sched/Makefile
-+++ linux-2.6.23.17/net/sched/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_NET_SCH_GRED) += sch_gred.o
+--- a/net/sched/Makefile
++++ b/net/sched/Makefile
+@@ -22,6 +22,7 @@
obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o
obj-$(CONFIG_NET_SCH_DSMARK) += sch_dsmark.o
obj-$(CONFIG_NET_SCH_SFQ) += sch_sfq.o
@@ -94,10 +88,8 @@ Index: linux-2.6.23.17/net/sched/Makefile
obj-$(CONFIG_NET_SCH_TBF) += sch_tbf.o
obj-$(CONFIG_NET_SCH_TEQL) += sch_teql.o
obj-$(CONFIG_NET_SCH_PRIO) += sch_prio.o
-Index: linux-2.6.23.17/net/sched/sch_esfq.c
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/net/sched/sch_esfq.c
++++ b/net/sched/sch_esfq.c
@@ -0,0 +1,702 @@
+/*
+ * net/sched/sch_esfq.c Extended Stochastic Fairness Queueing discipline.