aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
commit127d15a775b51296ab6eda47e9b116f988bebd7c (patch)
tree63364c73ceef57da30ee5a6669865d095b09c5bc /target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch
parentbdd7f3c7baeeb20ff5838ca685a3305de7d818ba (diff)
downloadmaster-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.tar.gz
master-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.tar.bz2
master-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.zip
add proper 2.6.25 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10865 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch b/target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch
new file mode 100644
index 0000000000..13427f1459
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/920-gpio_dev.patch
@@ -0,0 +1,35 @@
+Index: linux-2.6.23.14/arch/arm/Kconfig
+===================================================================
+--- linux-2.6.23.14.orig/arch/arm/Kconfig 2008-01-26 02:46:18.000000000 +0100
++++ linux-2.6.23.14/arch/arm/Kconfig 2008-01-26 02:46:33.000000000 +0100
+@@ -1039,6 +1039,8 @@
+
+ source "drivers/leds/Kconfig"
+
++source "drivers/gpio/Kconfig"
++
+ source "drivers/media/Kconfig"
+
+ source "drivers/video/Kconfig"
+Index: linux-2.6.23.14/drivers/Kconfig
+===================================================================
+--- linux-2.6.23.14.orig/drivers/Kconfig 2008-01-26 02:45:44.000000000 +0100
++++ linux-2.6.23.14/drivers/Kconfig 2008-01-26 02:46:05.000000000 +0100
+@@ -74,6 +74,8 @@
+
+ source "drivers/leds/Kconfig"
+
++source "drivers/gpio/Kconfig"
++
+ source "drivers/infiniband/Kconfig"
+
+ source "drivers/edac/Kconfig"
+Index: linux-2.6.23.14/drivers/Makefile
+===================================================================
+--- linux-2.6.23.14.orig/drivers/Makefile 2008-01-26 02:44:13.000000000 +0100
++++ linux-2.6.23.14/drivers/Makefile 2008-01-26 02:44:42.000000000 +0100
+@@ -91,3 +91,4 @@
+ obj-$(CONFIG_OF) += of/
+ obj-$(CONFIG_SSB) += ssb/
+ obj-$(CONFIG_VIRTIO) += virtio/
++obj-$(CONFIG_GPIO_DEVICE) += gpio/