aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-06-14 09:45:26 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-06-14 09:45:26 +0000
commitfe4e77367830da712de4ae30c3351debdaa72888 (patch)
treea62fab44a3ec4f3733888ff6e22ca6d44147e1ea /target/linux/generic-2.6/patches-2.6.28
parentc90997179f087802818b0a8f2bcc25649a78d1de (diff)
downloadmaster-187ad058-fe4e77367830da712de4ae30c3351debdaa72888.tar.gz
master-187ad058-fe4e77367830da712de4ae30c3351debdaa72888.tar.bz2
master-187ad058-fe4e77367830da712de4ae30c3351debdaa72888.zip
[kernel] refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16444 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch19
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch2
4 files changed, 7 insertions, 18 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch b/target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch
index ed95bcdc1c..fcfa792806 100644
--- a/target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/023-mips_delay_gcc4.4.0.patch
@@ -21,11 +21,9 @@ Signed-off-by: Wu Zhangjin <wuzhangjin@gmail.com>
arch/mips/include/asm/delay.h | 58 +++++++++++++++++++++++++------------
3 files changed, 57 insertions(+), 20 deletions(-)
-diff --git a/arch/mips/Makefile b/arch/mips/Makefile
-index a25c2e5..1ee5504 100644
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -120,7 +120,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r4300 -Wa,--trap
+@@ -119,7 +119,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r43
cflags-$(CONFIG_CPU_VR41XX) += -march=r4100 -Wa,--trap
cflags-$(CONFIG_CPU_R4X00) += -march=r4600 -Wa,--trap
cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
@@ -41,8 +39,6 @@ index a25c2e5..1ee5504 100644
cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
-Wa,-mips32 -Wa,--trap
cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
-diff --git a/arch/mips/include/asm/compiler.h b/arch/mips/include/asm/compiler.h
-index 71f5c5c..95256a8 100644
--- a/arch/mips/include/asm/compiler.h
+++ b/arch/mips/include/asm/compiler.h
@@ -1,5 +1,6 @@
@@ -66,8 +62,6 @@ index 71f5c5c..95256a8 100644
+#endif
+
#endif /* _ASM_COMPILER_H */
-diff --git a/arch/mips/include/asm/delay.h b/arch/mips/include/asm/delay.h
-index b0bccd2..00d7969 100644
--- a/arch/mips/include/asm/delay.h
+++ b/arch/mips/include/asm/delay.h
@@ -7,6 +7,7 @@
@@ -78,7 +72,7 @@ index b0bccd2..00d7969 100644
*/
#ifndef _ASM_DELAY_H
#define _ASM_DELAY_H
-@@ -48,6 +49,43 @@ static inline void __delay(unsigned long loops)
+@@ -48,6 +49,43 @@ static inline void __delay(unsigned long
: "0" (loops), "r" (1));
}
@@ -122,7 +116,7 @@ index b0bccd2..00d7969 100644
/*
* Division by multiplication: you don't have to worry about
-@@ -62,8 +100,6 @@ static inline void __delay(unsigned long loops)
+@@ -62,8 +100,6 @@ static inline void __delay(unsigned long
static inline void __udelay(unsigned long usecs, unsigned long lpj)
{
@@ -131,7 +125,7 @@ index b0bccd2..00d7969 100644
/*
* The rates of 128 is rounded wrongly by the catchall case
* for 64-bit. Excessive precission? Probably ...
-@@ -77,23 +113,7 @@ static inline void __udelay(unsigned long usecs, unsigned long lpj)
+@@ -77,23 +113,7 @@ static inline void __udelay(unsigned lon
0x80000000ULL) >> 32);
#endif
@@ -156,8 +150,3 @@ index b0bccd2..00d7969 100644
}
#define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
---
-1.6.0.4
-
-
-
diff --git a/target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch
index 34dd2b3e19..4844893f3b 100644
--- a/target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/202-mips-freestanding.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -586,6 +586,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927) += arch/
+@@ -593,6 +593,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927) += arch/
core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
core-$(CONFIG_TOSHIBA_RBTX4939) += arch/mips/txx9/rbtx4939/
diff --git a/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
index ca25aeda99..9d9ae5023e 100644
--- a/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
@@ -27,7 +27,7 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI
-@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
goto out;
}
diff --git a/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch b/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
index 8168742eba..023bf295e7 100644
--- a/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
@@ -67,7 +67,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p
+@@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE));
}