aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/835-gpiodev.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
commita3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741 (patch)
treeddcbfa29bdb1ce96cc700e7ed428a098053ecf8f /target/linux/generic/patches-3.0/835-gpiodev.patch
parent2e55411ec7cfe7a8198b9c2a2ba771600ec882a9 (diff)
downloadmaster-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.gz
master-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.bz2
master-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.zip
linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27191 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.0/835-gpiodev.patch')
-rw-r--r--target/linux/generic/patches-3.0/835-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.0/835-gpiodev.patch b/target/linux/generic/patches-3.0/835-gpiodev.patch
new file mode 100644
index 0000000000..f41d5a6850
--- /dev/null
+++ b/target/linux/generic/patches-3.0/835-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -511,6 +511,14 @@ config NSC_GPIO
+ pc8736x_gpio drivers. If those drivers are built as
+ modules, this one will be too, named nsc_gpio
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -47,6 +47,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+