aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-21 17:55:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-21 17:55:49 +0000
commit90b4f720be8b33dba4800f87ce22e6152011ce0e (patch)
treefab1d2fe086dbd97444d68ae56801d138172c84c /target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch
parentccbea572631693f82ed2f86571d4fb9624ac7a86 (diff)
downloadmaster-187ad058-90b4f720be8b33dba4800f87ce22e6152011ce0e.tar.gz
master-187ad058-90b4f720be8b33dba4800f87ce22e6152011ce0e.tar.bz2
master-187ad058-90b4f720be8b33dba4800f87ce22e6152011ce0e.zip
kernel/3.10: add separate rootfs partition parser
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38110 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch')
-rw-r--r--target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch b/target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch
new file mode 100644
index 0000000000..b3ff9d9ab2
--- /dev/null
+++ b/target/linux/generic/patches-3.10/406-mtd-add-squashfs-parser.patch
@@ -0,0 +1,30 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -37,6 +37,17 @@ config MTD_UIMAGE_SPLIT
+ depends on MTD_SPLIT_FIRMWARE
+ default y
+
++comment "Rootfs partition parsers"
++
++config MTD_SPLIT_SQUASHFS_ROOT
++ bool "Squashfs based root partition parser"
++ select MTD_SPLIT
++ default n
++ help
++ This provides a parsing function which allows to detect the
++ offset and size of the unused portion of a rootfs partition
++ containing a squashfs.
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o