aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/720-phy_adm6996.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commit3c5635a3aa3dd00eb47cf0191588ed64f6d10f29 (patch)
tree6b6bd393ef7dac1fdb3f9503f6bfc07e09b2ad25 /target/linux/generic/patches-3.10/720-phy_adm6996.patch
parent8ef2514fb69dce5191f3e967a68663d9baa5f6d0 (diff)
downloadmaster-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.gz
master-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.bz2
master-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.10/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-3.10/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/720-phy_adm6996.patch b/target/linux/generic/patches-3.10/720-phy_adm6996.patch
new file mode 100644
index 0000000000..65b206da3e
--- /dev/null
+++ b/target/linux/generic/patches-3.10/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -120,6 +120,13 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o