aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit2b43bb49dec4546cdca7e627b06e7682ae742591 (patch)
tree0d58c3ccdefbe53983cda5399612b4727f0ee81d /target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
parent3be7023c9be4e1381699ce393638ad63565c9ac5 (diff)
downloadmaster-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.gz
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.bz2
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
new file mode 100644
index 0000000000..c0568eb8d1
--- /dev/null
+++ b/target/linux/generic/patches-3.14/832-ledtrig_usbdev.patch
@@ -0,0 +1,31 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -62,3 +62,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
+ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+--- a/drivers/leds/ledtrig-usbdev.c
++++ b/drivers/leds/ledtrig-usbdev.c
+@@ -24,7 +24,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/slab.h>