aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
commit8f979de5a1b78dc4a4a0eb31b6ee33a46cd05405 (patch)
tree5039fd0ff8cfb7e66fbbc575c9cf8dacf62eeb17 /target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
parentd3d69d8a8cee37835d99487e65bb5156ef916dc5 (diff)
downloadmaster-187ad058-8f979de5a1b78dc4a4a0eb31b6ee33a46cd05405.tar.gz
master-187ad058-8f979de5a1b78dc4a4a0eb31b6ee33a46cd05405.tar.bz2
master-187ad058-8f979de5a1b78dc4a4a0eb31b6ee33a46cd05405.zip
generic: early (incomplete!) 4.0 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44511 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..36776a9c47
--- /dev/null
+++ b/target/linux/generic/patches-4.0/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1537,3 +1537,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -102,6 +102,8 @@ obj-$(CONFIG_CRYPTO_USER_API_HASH) += al
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #