aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
committerRod Whitby <rod@whitby.id.au>2007-12-07 22:29:44 +0000
commit3ee0e62c160b6b84172c71aa7f4ddc22fbc90ebd (patch)
tree188fb9f7cc4f65d6a094a0e4089e14b214f8834e /target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
parent907afd88a1999634568baefcaaff5018892c8938 (diff)
downloadmaster-187ad058-3ee0e62c160b6b84172c71aa7f4ddc22fbc90ebd.tar.gz
master-187ad058-3ee0e62c160b6b84172c71aa7f4ddc22fbc90ebd.tar.bz2
master-187ad058-3ee0e62c160b6b84172c71aa7f4ddc22fbc90ebd.zip
ixp4xx: Split into two subtargets, one normal and one for boards which boot directly from attached storage (and therefore need most kernel modules compiled in)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9669 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx/generic/profiles/300-NAS100d.mk')
-rw-r--r--target/linux/ixp4xx/generic/profiles/300-NAS100d.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
new file mode 100644
index 0000000000..2a43ac6d9b
--- /dev/null
+++ b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+ NAME:=Iomega NAS 100d
+ PACKAGES:=kmod-ixp4xx-npe \
+ kmod-madwifi wireless-tools \
+ kmod-scsi-core \
+ kmod-ata-core kmod-ata-artop \
+ kmod-usb-core kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NAS100d/Description
+ Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+