aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-05 08:25:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-05 08:25:45 +0000
commit717bb2a9cfa4ea7804db066746c5618aa747d508 (patch)
tree5dc258adc647d10c5431fbc84cc5eb38b47a1a00 /target/linux/kirkwood
parent4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc (diff)
downloadmaster-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.tar.gz
master-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.tar.bz2
master-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.zip
kernel: update 3.10 to 3.10.18
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38652 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/Makefile2
-rw-r--r--target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch2
-rw-r--r--target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch4
-rw-r--r--target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch2
-rw-r--r--target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch2
-rw-r--r--target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch12
-rw-r--r--target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch8
7 files changed, 16 insertions, 16 deletions
diff --git a/target/linux/kirkwood/Makefile b/target/linux/kirkwood/Makefile
index 60af7a2443..9ddcc79c6b 100644
--- a/target/linux/kirkwood/Makefile
+++ b/target/linux/kirkwood/Makefile
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand ubifs
CPU_TYPE:=xscale
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch b/target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch
index 0974985105..8e3887f5d0 100644
--- a/target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch
+++ b/target/linux/kirkwood/patches-3.10/0020-net-mv643xx_eth-use-phy_disconnect-instead-of-phy_de.patch
@@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2805,7 +2805,7 @@ static int mv643xx_eth_remove(struct pla
+@@ -2803,7 +2803,7 @@ static int mv643xx_eth_remove(struct pla
unregister_netdev(mp->dev);
if (mp->phy != NULL)
diff --git a/target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch b/target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch
index caf4d10850..a7c5628482 100644
--- a/target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch
+++ b/target/linux/kirkwood/patches-3.10/0021-net-mv643xx_eth-use-managed-devm_ioremap-for-port-re.patch
@@ -14,7 +14,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2470,7 +2470,7 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2469,7 +2469,7 @@ static int mv643xx_eth_shared_probe(stru
if (msp == NULL)
return -ENOMEM;
@@ -23,7 +23,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (msp->base == NULL)
return -ENOMEM;
-@@ -2498,7 +2498,6 @@ static int mv643xx_eth_shared_remove(str
+@@ -2497,7 +2497,6 @@ static int mv643xx_eth_shared_remove(str
{
struct mv643xx_eth_shared_private *msp = platform_get_drvdata(pdev);
diff --git a/target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch b/target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch
index 71e1a398ae..3179b901f7 100644
--- a/target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch
+++ b/target/linux/kirkwood/patches-3.10/0023-net-mv643xx_eth-use-of_phy_connect-if-phy_node-prese.patch
@@ -23,7 +23,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
static char mv643xx_eth_driver_name[] = "mv643xx_eth";
static char mv643xx_eth_driver_version[] = "1.4";
-@@ -2715,17 +2716,27 @@ static int mv643xx_eth_probe(struct plat
+@@ -2714,17 +2715,27 @@ static int mv643xx_eth_probe(struct plat
netif_set_real_num_tx_queues(dev, mp->txq_count);
netif_set_real_num_rx_queues(dev, mp->rxq_count);
diff --git a/target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch b/target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch
index 50bafd3474..7cf45a0db0 100644
--- a/target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch
+++ b/target/linux/kirkwood/patches-3.10/0024-net-mv643xx_eth-proper-initialization-for-Kirkwood-S.patch
@@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
#define TX_BW_RATE 0x0050
#define TX_BW_MTU 0x0058
#define TX_BW_BURST 0x005c
-@@ -2701,6 +2703,15 @@ static int mv643xx_eth_probe(struct plat
+@@ -2700,6 +2702,15 @@ static int mv643xx_eth_probe(struct plat
mp->dev = dev;
diff --git a/target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch b/target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch
index 897b261745..e0eac008be 100644
--- a/target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch
+++ b/target/linux/kirkwood/patches-3.10/0025-net-mv643xx_eth-add-DT-parsing-support.patch
@@ -116,7 +116,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
#include <linux/of_mdio.h>
static char mv643xx_eth_driver_name[] = "mv643xx_eth";
-@@ -2453,13 +2456,148 @@ static void infer_hw_params(struct mv643
+@@ -2452,13 +2455,148 @@ static void infer_hw_params(struct mv643
}
}
@@ -266,7 +266,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (!mv643xx_eth_version_printed++)
pr_notice("MV-643xx 10/100/1000 ethernet driver version %s\n",
-@@ -2472,6 +2610,7 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2471,6 +2609,7 @@ static int mv643xx_eth_shared_probe(stru
msp = devm_kzalloc(&pdev->dev, sizeof(*msp), GFP_KERNEL);
if (msp == NULL)
return -ENOMEM;
@@ -274,7 +274,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
msp->base = devm_ioremap(&pdev->dev, res->start, resource_size(res));
if (msp->base == NULL)
-@@ -2488,12 +2627,15 @@ static int mv643xx_eth_shared_probe(stru
+@@ -2487,12 +2626,15 @@ static int mv643xx_eth_shared_probe(stru
if (dram)
mv643xx_eth_conf_mbus_windows(msp, dram);
@@ -292,7 +292,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
return 0;
}
-@@ -2501,9 +2643,9 @@ static int mv643xx_eth_shared_remove(str
+@@ -2500,9 +2642,9 @@ static int mv643xx_eth_shared_remove(str
{
struct mv643xx_eth_shared_private *msp = platform_get_drvdata(pdev);
@@ -303,7 +303,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
return 0;
}
-@@ -2513,6 +2655,7 @@ static struct platform_driver mv643xx_et
+@@ -2512,6 +2654,7 @@ static struct platform_driver mv643xx_et
.driver = {
.name = MV643XX_ETH_SHARED_NAME,
.owner = THIS_MODULE,
@@ -311,7 +311,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
},
};
-@@ -2721,6 +2864,8 @@ static int mv643xx_eth_probe(struct plat
+@@ -2720,6 +2863,8 @@ static int mv643xx_eth_probe(struct plat
if (!IS_ERR(mp->clk)) {
clk_prepare_enable(mp->clk);
mp->t_clk = clk_get_rate(mp->clk);
diff --git a/target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch b/target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch
index 84ac77991c..12e522a1f8 100644
--- a/target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch
+++ b/target/linux/kirkwood/patches-3.10/0029-net-mv643xx_eth-do-not-use-port-number-as-platform-d.patch
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -2483,6 +2483,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2482,6 +2482,7 @@ static int mv643xx_eth_shared_of_add_por
struct resource res;
const char *mac_addr;
int ret;
@@ -27,7 +27,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
memset(&ppd, 0, sizeof(ppd));
ppd.shared = pdev;
-@@ -2503,6 +2504,14 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2502,6 +2503,14 @@ static int mv643xx_eth_shared_of_add_por
return -EINVAL;
}
@@ -42,7 +42,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
mac_addr = of_get_mac_address(pnp);
if (mac_addr)
memcpy(ppd.mac_addr, mac_addr, 6);
-@@ -2521,7 +2530,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2520,7 +2529,7 @@ static int mv643xx_eth_shared_of_add_por
of_property_read_u32(pnp, "duplex", &ppd.duplex);
}
@@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (!ppdev)
return -ENOMEM;
ppdev->dev.coherent_dma_mask = DMA_BIT_MASK(32);
-@@ -2538,7 +2547,7 @@ static int mv643xx_eth_shared_of_add_por
+@@ -2537,7 +2546,7 @@ static int mv643xx_eth_shared_of_add_por
if (ret)
goto port_err;