aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-03 02:50:02 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-03 02:50:02 +0000
commit88cab0c554343f4952d1ed97c2343c4e2940cfe8 (patch)
treefc8bd101826172754a35c23940b1590faf99d3e1 /target/linux/kirkwood
parenta948ae90c210260106dcb411ed006d2ee13ade21 (diff)
downloadmaster-187ad058-88cab0c554343f4952d1ed97c2343c4e2940cfe8.tar.gz
master-187ad058-88cab0c554343f4952d1ed97c2343c4e2940cfe8.tar.bz2
master-187ad058-88cab0c554343f4952d1ed97c2343c4e2940cfe8.zip
kirkwood: fix initramfs images
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38296 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 1dfe45f494..dbf8877652 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,8 +10,10 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE := 2048:128k
define Image/BuildKernel
-# do mach-id fixup here, if needed
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(CP) $(KDIR)/uImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-uImage-initramfs
+endif
endef
define Image/Build