aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/falcon
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-12-16 10:03:23 +0000
committerJohn Crispin <blogic@openwrt.org>2012-12-16 10:03:23 +0000
commit10ddaf7cbc378be7ce614bfe7efa317ffb4b0b8c (patch)
tree2e830be085560db33807231ec414c77f52a7d764 /target/linux/lantiq/falcon
parentbcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57 (diff)
downloadmaster-187ad058-10ddaf7cbc378be7ce614bfe7efa317ffb4b0b8c.tar.gz
master-187ad058-10ddaf7cbc378be7ce614bfe7efa317ffb4b0b8c.tar.bz2
master-187ad058-10ddaf7cbc378be7ce614bfe7efa317ffb4b0b8c.zip
[lantiq] fix falcon profile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34713 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/falcon')
-rw-r--r--target/linux/lantiq/falcon/config-default5
-rw-r--r--target/linux/lantiq/falcon/profiles/000-generic.mk12
-rw-r--r--target/linux/lantiq/falcon/profiles/001-lantiq.mk24
-rw-r--r--target/linux/lantiq/falcon/profiles/lantiq.mk19
4 files changed, 24 insertions, 36 deletions
diff --git a/target/linux/lantiq/falcon/config-default b/target/linux/lantiq/falcon/config-default
index 88a6f3c5f0..fef4015f26 100644
--- a/target/linux/lantiq/falcon/config-default
+++ b/target/linux/lantiq/falcon/config-default
@@ -1,5 +1,9 @@
CONFIG_GPIO_FALCON=y
CONFIG_GPIO_GENERIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_CHARDEV=y
+# CONFIG_I2C_LANTIQ is not set
CONFIG_M25PXX_USE_FAST_READ=y
CONFIG_MTD_M25P80=y
CONFIG_MTD_NAND=y
@@ -7,6 +11,7 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_FALCON=y
CONFIG_MTD_NAND_PLATFORM=y
# CONFIG_MTD_SM_COMMON is not set
+CONFIG_OF_I2C=y
CONFIG_PINCTRL_FALCON=y
CONFIG_SOC_FALCON=y
# CONFIG_SOC_TYPE_XWAY is not set
diff --git a/target/linux/lantiq/falcon/profiles/000-generic.mk b/target/linux/lantiq/falcon/profiles/000-generic.mk
deleted file mode 100644
index 480e58eefe..0000000000
--- a/target/linux/lantiq/falcon/profiles/000-generic.mk
+++ /dev/null
@@ -1,12 +0,0 @@
-define Profile/Generic
- NAME:=Generic - all boards
- PACKAGES:= \
- kmod-dm9000 \
- kmod-i2c-core kmod-i2c-falcon-lantiq kmod-eeprom-at24 \
- kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25 \
- gpon-dti-agent
-endef
-
-$(eval $(call Profile,Generic))
-
-
diff --git a/target/linux/lantiq/falcon/profiles/001-lantiq.mk b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
deleted file mode 100644
index fa42b62d1f..0000000000
--- a/target/linux/lantiq/falcon/profiles/001-lantiq.mk
+++ /dev/null
@@ -1,24 +0,0 @@
-define Profile/EASY98000
- NAME:=EASY98000
- PACKAGES:= \
- kmod-dm9000 \
- kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
- kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
-endef
-
-define Profile/EASY98000/Description
- Lantiq EASY98000 evalkit
-endef
-
-$(eval $(call Profile,EASY98000))
-
-define Profile/EASY98020
- NAME:=EASY98020
-endef
-
-define Profile/EASY98020/Description
- Lantiq EASY98020 evalkit
-endef
-
-$(eval $(call Profile,EASY98020))
-
diff --git a/target/linux/lantiq/falcon/profiles/lantiq.mk b/target/linux/lantiq/falcon/profiles/lantiq.mk
new file mode 100644
index 0000000000..ab60ff58a6
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/lantiq.mk
@@ -0,0 +1,19 @@
+define Profile/EASY98000NOR
+ NAME:=Lantiq Falcon - EASY98000NOR
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000NOR))
+
+define Profile/EASY98000SFLASH
+ NAME:=Lantiq Falcon - EASY98000SFLASH
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000SFLASH))