aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 10:02:30 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 10:02:30 +0000
commitd2b1dccc38a7113ce65b53eb549ffff203844cb2 (patch)
tree64c528d045755f6aefdec1156fd17ec5a68db1fa /target/linux/lantiq/image
parent7081cc98e11fd6f1b798e44ee16439e57bac089f (diff)
downloadmaster-187ad058-d2b1dccc38a7113ce65b53eb549ffff203844cb2.tar.gz
master-187ad058-d2b1dccc38a7113ce65b53eb549ffff203844cb2.tar.bz2
master-187ad058-d2b1dccc38a7113ce65b53eb549ffff203844cb2.zip
lntiq: add support for Astoria ARV7519RW.
These patches add support for the Astoria ARV7519RW aka Livebox 2.1 The PCI and PCIe interfaces have been disabled. Also, because there are two revisions of this board with different GPHY firmwares, two targets were defined. V2: rewrote partitions to work with an u-boot specifically made for these boards. Signed off by: Esteban Benito <estebanjbs@gmail.com> Signed off by: Carles Gadea <carlesgrg@gmail.com> Tested by: José Vázquez Fernández <ppvazquezfer@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40329 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index cd36d12ca1..28cb96c8b7 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -307,6 +307,12 @@ Image/Build/Profile/H201L=$(call Image/Build/$(1),$(1),H201L)
Image/BuildKernel/Profile/P2601HNFX=$(call Image/BuildKernel/Template,P2601HNFX)
Image/Build/Profile/P2601HNFX=$(call Image/Build/$(1),$(1),P2601HNFX)
+Image/BuildKernel/Profile/ARV7519RWV11=$(call Image/BuildKernel/Template,ARV7519RWV11,$(1))
+Image/Build/Profile/ARV7519RWV11=$(call Image/Build/$(1), $(1),ARV7519RWV11)
+
+Image/BuildKernel/Profile/ARV7519RWV12=$(call Image/BuildKernel/Template,ARV7519RWV12,$(1))
+Image/Build/Profile/ARV7519RWV12=$(call Image/Build/$(1), $(1),ARV7519RWV12)
+
endif