aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-02-28 11:09:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-02-28 11:09:34 +0000
commitd99b1b4dbde632a7b6fc08f4ee9a375741074919 (patch)
tree24c28fc5ee58cf95181dfdbf0eda197d9a0c7517 /target/linux/malta/image/Makefile
parent2002fb26a545a54a0cf57151f254e532270f21f6 (diff)
downloadmaster-187ad058-d99b1b4dbde632a7b6fc08f4ee9a375741074919.tar.gz
master-187ad058-d99b1b4dbde632a7b6fc08f4ee9a375741074919.tar.bz2
master-187ad058-d99b1b4dbde632a7b6fc08f4ee9a375741074919.zip
[malta] add a MIPS Malta target to be used with qemu
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19893 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/malta/image/Makefile')
-rw-r--r--target/linux/malta/image/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
new file mode 100644
index 0000000000..16e21a70c1
--- /dev/null
+++ b/target/linux/malta/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))