aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-28 15:51:32 +0000
commit73bc23732b56b4aba09f40130effed9c32afcfaa (patch)
tree7a9cc2d200c92b026f9b5225a5000de5499b7564 /target/linux/mpc52xx/image
parentd1b4d6e36a49733d97efcae84ccff8037a45e91d (diff)
downloadmaster-187ad058-73bc23732b56b4aba09f40130effed9c32afcfaa.tar.gz
master-187ad058-73bc23732b56b4aba09f40130effed9c32afcfaa.tar.bz2
master-187ad058-73bc23732b56b4aba09f40130effed9c32afcfaa.zip
[mpc52xx] add new target for Freescale MPC52xx based boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc52xx/image')
-rw-r--r--target/linux/mpc52xx/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/mpc52xx/image/Makefile b/target/linux/mpc52xx/image/Makefile
new file mode 100644
index 0000000000..177ca07bb7
--- /dev/null
+++ b/target/linux/mpc52xx/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+endef
+
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))