aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-09 11:45:04 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-09 11:45:04 +0000
commit230ccbe23de554b2601e6f109a378a5c57e53eea (patch)
tree7002b694ed5b647aba5ee2398ef079b103259d5d /target/linux/mpc83xx/image
parentdb1775f489e4d00c921ecc236df2255022e3106b (diff)
downloadmaster-187ad058-230ccbe23de554b2601e6f109a378a5c57e53eea.tar.gz
master-187ad058-230ccbe23de554b2601e6f109a378a5c57e53eea.tar.bz2
master-187ad058-230ccbe23de554b2601e6f109a378a5c57e53eea.zip
add preliminary MPC83xx support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18353 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx/image')
-rw-r--r--target/linux/mpc83xx/image/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
new file mode 100644
index 0000000000..1483786e8f
--- /dev/null
+++ b/target/linux/mpc83xx/image/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
+endef
+
+$(eval $(call BuildImage))