aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commit9d42bb1a218d092b8c9447cf16ec2c94f7881c8d (patch)
tree422842a370190fdfcc59b10055cbbf761974bb76 /target/linux/mpc83xx/image
parentdebf59c4e6f85df3132eae86b2e8c8399040c1ce (diff)
downloadmaster-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.gz
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.bz2
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20834 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx/image')
-rw-r--r--target/linux/mpc83xx/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
index 0d5c380f85..9337016e08 100644
--- a/target/linux/mpc83xx/image/Makefile
+++ b/target/linux/mpc83xx/image/Makefile
@@ -7,14 +7,13 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-
define Image/Prepare
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/mpc8377_wlan.dts > $(BIN_DIR)/openwrt-mpc83xx-mpc8377_wlan.dtb
endef
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
- cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/$(IMG_PREFIX)-rb600.elf
+ cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
define Image/Build
@@ -26,7 +25,7 @@ define Image/Build/squashfs
( \
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=3072k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-mpc8377_wlan-$(1).img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-mpc8377_wlan-$(1).img
endef
$(eval $(call BuildImage))