aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/modules.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-26 10:40:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-26 10:40:47 +0000
commitb21cebc6e0ff40aaa1236909779ae98de7f02948 (patch)
tree20b7a3611043a56bc787f9e680cb14b9e15ee73c /target/linux/mpc83xx/modules.mk
parentf12c1287396df20bd10fa2dd69f08024e9ef5b06 (diff)
downloadmaster-187ad058-b21cebc6e0ff40aaa1236909779ae98de7f02948.tar.gz
master-187ad058-b21cebc6e0ff40aaa1236909779ae98de7f02948.tar.bz2
master-187ad058-b21cebc6e0ff40aaa1236909779ae98de7f02948.zip
mpc83xx: create package for the rbppc_cf module
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34888 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx/modules.mk')
-rw-r--r--target/linux/mpc83xx/modules.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mpc83xx/modules.mk b/target/linux/mpc83xx/modules.mk
new file mode 100644
index 0000000000..dd65d112f4
--- /dev/null
+++ b/target/linux/mpc83xx/modules.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-rbppc-cf
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=RB600 Compact Flash support
+ DEPENDS:=@TARGET_mpc83xx
+ KCONFIG:= \
+ CONFIG_PATA_PLATFORM \
+ CONFIG_PATA_RB_PPC
+ FILES:=\
+ $(LINUX_DIR)/drivers/ata/pata_rbppc_cf.ko
+ AUTOLOAD:=$(call AutoLoad,41,pata_rbppc_cf,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-rbppc-cf/description
+ RB600 Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-rbppc-cf))