aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-12 17:29:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-12 17:29:50 +0000
commit99888c7af5e9a8363a29bee424d8a803b52e0210 (patch)
treebcab44caa20552eddce7b3fd7bd4b5823562a2d6 /target/linux/mvebu/image/Makefile
parent18bcf252f753dbef88ac98b3de86e513f8c7cc48 (diff)
downloadmaster-187ad058-99888c7af5e9a8363a29bee424d8a803b52e0210.tar.gz
master-187ad058-99888c7af5e9a8363a29bee424d8a803b52e0210.tar.bz2
master-187ad058-99888c7af5e9a8363a29bee424d8a803b52e0210.zip
mvebu: migrate mamba support to the upstreamed code
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45400 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index da7d2174e5..443110113c 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -137,7 +137,7 @@ $(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
# Boards with NAND, with subpages
-$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512,2048))
+$(eval $(call NANDProfile,Mamba,armada-xp-linksys-mamba,128KiB,2048,512,2048))
# Boards with large NOR, where we want to use UBI
$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
@@ -146,12 +146,12 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
define Image/Build/Profile/Mamba/squashfs
- $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
+ $(call Image/Build/UbinizeImage,armada-xp-linksys-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
( \
- dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
- dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
+ dd if=$(KDIR)/uImage-armada-xp-linksys-mamba bs=3072k conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-ubinized.bin \
bs=2048 conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-factory.img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
# The Default profile should build everything