aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-01-15 18:38:51 +0000
committerLuka Perkov <luka@openwrt.org>2014-01-15 18:38:51 +0000
commit830cc0c62192312fa368c18515c893e37345fcdf (patch)
tree3c4990b99ac57ddfc15b7de445794578ac567bc6 /target/linux/mvebu/image
parentd356a6f223cd6bbeafa41460b47fe360946838ae (diff)
downloadmaster-187ad058-830cc0c62192312fa368c18515c893e37345fcdf.tar.gz
master-187ad058-830cc0c62192312fa368c18515c893e37345fcdf.tar.bz2
master-187ad058-830cc0c62192312fa368c18515c893e37345fcdf.zip
mvebu: fix build failures when initramfs is not selected
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39301 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index af29c2baae..1e4a7910e3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -30,7 +30,9 @@ endef
define Image/BuildKernel
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/DTB,$(dtb)))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Initramfs)
+ endif
endef
define Image/Build/squashfs