aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-04 15:23:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-04 15:23:05 +0000
commitfa4b78484a6b1ff7ed74d781c17cfb002fae361e (patch)
tree32e9f9628dd69a2be0491b4e1a2ae005fc69d684 /target/linux/octeon/image/Makefile
parent591c58781f6324d16bfc4541429d6142d8a80ee0 (diff)
downloadmaster-187ad058-fa4b78484a6b1ff7ed74d781c17cfb002fae361e.tar.gz
master-187ad058-fa4b78484a6b1ff7ed74d781c17cfb002fae361e.tar.bz2
master-187ad058-fa4b78484a6b1ff7ed74d781c17cfb002fae361e.zip
octeon: R.I.P.
It is broken since ~8 months and nobody takes care of that. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35486 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/octeon/image/Makefile')
-rw-r--r--target/linux/octeon/image/Makefile26
1 files changed, 0 insertions, 26 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
deleted file mode 100644
index 358bbe8aae..0000000000
--- a/target/linux/octeon/image/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/BuildKernel
- # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
- $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
- dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
-define Image/Build
- $(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
-endef
-
-$(eval $(call BuildImage))