aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/olpc
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-12 17:49:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-12 17:49:01 +0000
commit244eec7994d5cebae890294e94b8c2ecacfb8b05 (patch)
tree701089c26274a474abbf02d62843dd79187ca46b /target/linux/olpc
parent688d7f7df84b28a425f5eee0d8ec9631a5075d25 (diff)
downloadmaster-187ad058-244eec7994d5cebae890294e94b8c2ecacfb8b05.tar.gz
master-187ad058-244eec7994d5cebae890294e94b8c2ecacfb8b05.tar.bz2
master-187ad058-244eec7994d5cebae890294e94b8c2ecacfb8b05.zip
[kernel] update to 2.6.25.20, 2.6.26.8, 2.6.27.5 and refresh patches
* based on a patch by Hauke Mehrtens * closes #4193 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13192 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/olpc')
-rw-r--r--target/linux/olpc/Makefile2
-rw-r--r--target/linux/olpc/patches-2.6.27/300-block2mtd_init.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
index 1ece675b8f..455031a9fd 100644
--- a/target/linux/olpc/Makefile
+++ b/target/linux/olpc/Makefile
@@ -11,7 +11,7 @@ BOARD:=olpc
BOARDNAME:=OLPC XO-1
FEATURES:=squashfs ext2
-LINUX_VERSION:=2.6.27.4
+LINUX_VERSION:=2.6.27.5
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
diff --git a/target/linux/olpc/patches-2.6.27/300-block2mtd_init.patch b/target/linux/olpc/patches-2.6.27/300-block2mtd_init.patch
index dc7f7dfba7..e16570fdd1 100644
--- a/target/linux/olpc/patches-2.6.27/300-block2mtd_init.patch
+++ b/target/linux/olpc/patches-2.6.27/300-block2mtd_init.patch
@@ -69,7 +69,7 @@
static struct page *page_read(struct address_space *mapping, int index)
{
-@@ -510,7 +542,9 @@ static int block2mtd_setup2(const char *val)
+@@ -510,7 +542,9 @@ static int block2mtd_setup2(const char *
if (token[2] && (strlen(token[2]) + 1 > 80))
parse_err("mtd device name too long");
@@ -100,7 +100,7 @@
VMLINUX_SYMBOL(__per_cpu_start) = .; \
--- a/init/do_mounts.c
+++ b/init/do_mounts.c
-@@ -174,16 +174,8 @@ static int __init fs_names_setup(char *str)
+@@ -174,16 +174,8 @@ static int __init fs_names_setup(char *s
return 1;
}
@@ -185,7 +185,7 @@
static int __init kernel_init(void * unused)
{
lock_kernel();
-@@ -873,7 +882,16 @@ static int __init kernel_init(void * unused)
+@@ -873,7 +882,16 @@ static int __init kernel_init(void * unu
if (sys_access((const char __user *) ramdisk_execute_command, 0) != 0) {
ramdisk_execute_command = NULL;