aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2015-10-09 07:46:12 +0000
committerMichael Büsch <mb@bu3sch.de>2015-10-09 07:46:12 +0000
commit33e6506245c3a03b17d3344234af7dcc17a1f234 (patch)
treee832e027a45959dc88a69b09020aae5b7db146d1 /target/linux/omap24xx/image
parent702a54a6612d89d372364501c9f05052b18a4a17 (diff)
downloadmaster-187ad058-33e6506245c3a03b17d3344234af7dcc17a1f234.tar.gz
master-187ad058-33e6506245c3a03b17d3344234af7dcc17a1f234.tar.bz2
master-187ad058-33e6506245c3a03b17d3344234af7dcc17a1f234.zip
omap24xx: Append dtb to the zImage
We just hardcode the n810 dtb for now. It should be selectable via profiles. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47166 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap24xx/image')
-rw-r--r--target/linux/omap24xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 7a3429fa6c..316cce0f9f 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE=2048-128k
define Image/BuildKernel
- $(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ cat $(KDIR)/zImage $(DTS_DIR)/omap2420-n810.dtb > $(BIN_DIR)/$(IMG_PREFIX)-zImage
chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef