aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-02-12 06:00:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-02-12 06:00:38 +0000
commit3d9ed4425c9ee015f1384dfb5c4288ce5a15025d (patch)
treed604d47ed0783b1cb44ec9a1efb3c5cfb88fc203 /target/linux/package/base-files/Makefile
parent09634919d3524e15cce41331fe2504031bb19a9c (diff)
downloadmaster-187ad058-3d9ed4425c9ee015f1384dfb5c4288ce5a15025d.tar.gz
master-187ad058-3d9ed4425c9ee015f1384dfb5c4288ce5a15025d.tar.bz2
master-187ad058-3d9ed4425c9ee015f1384dfb5c4288ce5a15025d.zip
add support for netgear dg834 and the almost identical sphairon jdr454wb: new images, automatic boot loader patcher, updated flash script (dlink.pl renamed to adam2flash.pl) - Thanks to Jonathan McDowell (Noodles)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3221 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package/base-files/Makefile')
-rw-r--r--target/linux/package/base-files/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/package/base-files/Makefile b/target/linux/package/base-files/Makefile
index 637904c2e8..cf72eabdac 100644
--- a/target/linux/package/base-files/Makefile
+++ b/target/linux/package/base-files/Makefile
@@ -15,8 +15,21 @@ $(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR)
touch $@
+ifeq ($(BOARD),ar7)
+$(PKG_BUILD_DIR)/adam2patcher: src/adam2patcher.c
+ $(TARGET_CC) -o $@ $<
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/adam2patcher
+
+$(IDIR_OPENWRT)/sbin/adam2patcher: $(PKG_BUILD_DIR)/adam2patcher
+ mkdir -p $(IDIR_OPENWRT)/sbin
+ $(CP) $(PKG_BUILD_DIR)/adam2patcher $(IDIR_OPENWRT)/sbin
+
+$(IPKG_OPENWRT): $(IDIR_OPENWRT)/sbin/adam2patcher
+endif
+
ifeq ($(BOARD),brcm)
-$(PKG_BUILD_DIR)/jffs2root: jffs2root.c
+$(PKG_BUILD_DIR)/jffs2root: src/jffs2root.c
$(TARGET_CC) -o $@ $<
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/jffs2root