aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-07-29 14:52:31 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-07-29 14:52:31 +0000
commitcf001a84b3972a1f5f9e67d453646c7797247def (patch)
tree8d7b9912ff5ed8c503bcf86fe88b63130404d8c1 /target/linux/ppc40x
parent73bc23732b56b4aba09f40130effed9c32afcfaa (diff)
downloadmaster-187ad058-cf001a84b3972a1f5f9e67d453646c7797247def.tar.gz
master-187ad058-cf001a84b3972a1f5f9e67d453646c7797247def.tar.bz2
master-187ad058-cf001a84b3972a1f5f9e67d453646c7797247def.zip
ppc4xx optimizations
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17040 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc40x')
-rw-r--r--target/linux/ppc40x/Makefile1
-rw-r--r--target/linux/ppc40x/patches-2.6.30/004-magicbox.patch6
-rw-r--r--target/linux/ppc40x/patches-2.6.30/005-openrb.patch2
3 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 00a566910c..f4423391a5 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -10,6 +10,7 @@ ARCH:=powerpc
BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
FEATURES:=squashfs usb
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
LINUX_VERSION:=2.6.30.3
LINUX_KARCH:=powerpc
diff --git a/target/linux/ppc40x/patches-2.6.30/004-magicbox.patch b/target/linux/ppc40x/patches-2.6.30/004-magicbox.patch
index 72ca542c14..d6ce22d4a8 100644
--- a/target/linux/ppc40x/patches-2.6.30/004-magicbox.patch
+++ b/target/linux/ppc40x/patches-2.6.30/004-magicbox.patch
@@ -377,9 +377,9 @@
+};
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
-@@ -42,6 +42,7 @@ $(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
- $(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
- $(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
+@@ -42,6 +42,7 @@ $(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
$(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
+$(obj)/cuboot-magicbox.o: BOOTCFLAGS += -mcpu=405
$(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
diff --git a/target/linux/ppc40x/patches-2.6.30/005-openrb.patch b/target/linux/ppc40x/patches-2.6.30/005-openrb.patch
index 87de8777a2..43407c2025 100644
--- a/target/linux/ppc40x/patches-2.6.30/005-openrb.patch
+++ b/target/linux/ppc40x/patches-2.6.30/005-openrb.patch
@@ -354,7 +354,7 @@
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
@@ -43,6 +43,7 @@ $(obj)/cuboot-taishan.o: BOOTCFLAGS += -
- $(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
+ $(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
$(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
$(obj)/cuboot-magicbox.o: BOOTCFLAGS += -mcpu=405
+$(obj)/cuboot-openrb.o: BOOTCFLAGS += -mcpu=405