aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/patches/005-verdex_pcmcia_support.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-18 13:04:02 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-18 13:04:02 +0000
commitbc5d76f6ad14195024e3dbe2d6701f4116362f1d (patch)
treed4de41b2a6e639e2542257cd153ca280ca6bf284 /target/linux/pxa/patches/005-verdex_pcmcia_support.patch
parentaead77402213f52090323873277812aa419f1d1c (diff)
downloadmaster-187ad058-bc5d76f6ad14195024e3dbe2d6701f4116362f1d.tar.gz
master-187ad058-bc5d76f6ad14195024e3dbe2d6701f4116362f1d.tar.bz2
master-187ad058-bc5d76f6ad14195024e3dbe2d6701f4116362f1d.zip
[pxa]: upgrade to 2.6.37
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26224 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/pxa/patches/005-verdex_pcmcia_support.patch')
-rw-r--r--target/linux/pxa/patches/005-verdex_pcmcia_support.patch21
1 files changed, 11 insertions, 10 deletions
diff --git a/target/linux/pxa/patches/005-verdex_pcmcia_support.patch b/target/linux/pxa/patches/005-verdex_pcmcia_support.patch
index ca50022c67..c6a793e9f7 100644
--- a/target/linux/pxa/patches/005-verdex_pcmcia_support.patch
+++ b/target/linux/pxa/patches/005-verdex_pcmcia_support.patch
@@ -15,26 +15,27 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
--- a/drivers/pcmcia/Kconfig
+++ b/drivers/pcmcia/Kconfig
-@@ -221,7 +221,8 @@ config PCMCIA_PXA2XX
- depends on ARM && ARCH_PXA && PCMCIA
+@@ -215,7 +215,7 @@ config PCMCIA_PXA2XX
depends on (ARCH_LUBBOCK || MACH_MAINSTONE || PXA_SHARPSL \
|| MACH_ARMCORE || ARCH_PXA_PALM || TRIZEPS_PCMCIA \
-- || ARCH_VIPER || ARCH_PXA_ESERIES || MACH_STARGATE2)
-+ || ARCH_VIPER || ARCH_PXA_ESERIES || MACH_STARGATE2 \
-+ || ARCH_GUMSTIX)
+ || ARCOM_PCMCIA || ARCH_PXA_ESERIES || MACH_STARGATE2 \
+- || MACH_VPAC270 || MACH_BALLOON3)
++ || MACH_VPAC270 || MACH_BALLOON3 || ARCH_GUMSTIX)
+ select PCMCIA_SOC_COMMON
help
Say Y here to include support for the PXA2xx PCMCIA controller
-
--- a/drivers/pcmcia/Makefile
+++ b/drivers/pcmcia/Makefile
-@@ -77,4 +77,7 @@ pxa2xx-obj-$(CONFIG_MACH_PALMLD) += pxa
- pxa2xx-obj-$(CONFIG_MACH_E740) += pxa2xx_e740.o
- pxa2xx-obj-$(CONFIG_MACH_STARGATE2) += pxa2xx_stargate2.o
+@@ -71,6 +71,9 @@ pxa2xx-obj-$(CONFIG_MACH_STARGATE2) +=
+ pxa2xx-obj-$(CONFIG_MACH_VPAC270) += pxa2xx_vpac270.o
+ pxa2xx-obj-$(CONFIG_MACH_BALLOON3) += pxa2xx_balloon3.o
+pxa2xx-obj-$(CONFIG_MACH_GUMSTIX_VERDEX) += pxa2xx_cs.o
+pxa2xx_cs-objs := pxa2xx_gumstix.o
+
- obj-$(CONFIG_PCMCIA_PXA2XX) += pxa2xx_core.o $(pxa2xx-obj-y)
+ obj-$(CONFIG_PCMCIA_PXA2XX) += pxa2xx_base.o $(pxa2xx-obj-y)
+
+ obj-$(CONFIG_PCMCIA_XXS1500) += xxs1500_ss.o
--- /dev/null
+++ b/drivers/pcmcia/pxa2xx_gumstix.c
@@ -0,0 +1,194 @@