aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-14 20:51:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-14 20:51:26 +0000
commit8a07cba2b5a55b274bea5747981427f725aef9da (patch)
treea9d0336f744dc1d799a73bb0012dd1eb18a125e8 /target/linux/ramips/image/Makefile
parentdf79552a2b3d2409b9c1090a264cdd4a43cd42f0 (diff)
downloadmaster-187ad058-8a07cba2b5a55b274bea5747981427f725aef9da.tar.gz
master-187ad058-8a07cba2b5a55b274bea5747981427f725aef9da.tar.bz2
master-187ad058-8a07cba2b5a55b274bea5747981427f725aef9da.zip
ramips: add support for Omnima MiniEMBWiFi board
This patch adds support for the Omnima MiniEMBWiFi Ralink RT3050F based board. Based on a patch by Ivan Ignjatic <ivan at omnima.co.uk> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 24f59663cc..4f92d30ecd 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -139,6 +139,12 @@ define Image/Build/Template/NW718
$(call BuildFirmware/NW718,$(1),$(2),board=$(3),mtdlayout_nw718,851968,2949120)
endef
+console_OMNIEMB=ttyS1,57600
+mtdlayout_ONMIEMB=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/OMNIEMB
+ $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_OMNIEMB),mtdlayout_OMNIEMB,1048576,7012352)
+endef
+
define Image/Build/Profile/DIR300B1
$(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
$(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -173,6 +179,10 @@ define Image/Build/Profile/NW718
$(call Image/Build/Template/NW718,$(1),nw718,NW718)
endef
+define Image/Build/Profile/OMNIEMB
+ $(call Image/Build/Template/OMNIEMB,$(1),omni-emb,OMNI-EMB)
+endef
+
define Image/Build/Profile/PWH2004
$(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
endef
@@ -248,6 +258,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/V22RW2X2,$(1))
$(call Image/Build/Profile/NBG419N,$(1))
$(call Image/Build/Profile/NW718,$(1))
+ $(call Image/Build/Profile/OMNIEMB,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
$(call Image/Build/Profile/WHRG300N,$(1))
$(call Image/Build/Profile/WCR150GN,$(1))