aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7688.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-06-24 20:17:26 +0200
committerGitHub <noreply@github.com>2016-06-24 20:17:26 +0200
commit6eb05f9f38210bfd7cb667fab1b00e5ebd737556 (patch)
tree8adb7f0946f1c0f2fba4cc28999d915b167af464 /target/linux/ramips/image/mt7688.mk
parent282b917e47d9ae5017e1e426face9b75cb7aabd0 (diff)
parent64de7165e5bce0d6f811795bc5a0a81165eb58ca (diff)
downloadmaster-187ad058-6eb05f9f38210bfd7cb667fab1b00e5ebd737556.tar.gz
master-187ad058-6eb05f9f38210bfd7cb667fab1b00e5ebd737556.tar.bz2
master-187ad058-6eb05f9f38210bfd7cb667fab1b00e5ebd737556.zip
Merge pull request #12 from wigyori/master
update oxnas target, update ipq806x target, create trunk tag and update revisioning accordingly
Diffstat (limited to 'target/linux/ramips/image/mt7688.mk')
-rw-r--r--target/linux/ramips/image/mt7688.mk26
1 files changed, 21 insertions, 5 deletions
diff --git a/target/linux/ramips/image/mt7688.mk b/target/linux/ramips/image/mt7688.mk
index 45991d0874..ffd92d21c6 100644
--- a/target/linux/ramips/image/mt7688.mk
+++ b/target/linux/ramips/image/mt7688.mk
@@ -2,10 +2,26 @@
# MT7688 Profiles
#
-Image/Build/Profile/LinkIt7688=$(call BuildFirmware/Default32M/$(1),$(1),LinkIt7688,LINKIT7688)
-Image/Build/Profile/WRTNODE2R=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2r,WRTNODE2R)
+define Device/LinkIt7688
+ DTS := LINKIT7688
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := MediaTek LinkIt Smart 7688
+ DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci uboot-envtools
+endef
+TARGET_DEVICES += LinkIt7688
+
+define Device/wrtnode2r
+ DTS := WRTNODE2R
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := WRTnode 2R
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += wrtnode2r
-define Image/Build/Profile/Default
- $(call Image/Build/Profile/LinkIt7688,$(1))
- $(call Image/Build/Profile/WRTNODE2R,$(1))
+define Device/widora-neo
+ DTS := WIDORA-NEO
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Widora-NEO
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
endef
+TARGET_DEVICES += widora-neo