aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-01 22:48:42 +0000
commit33678d2d30351fb803cc4efb4e2293987ee32689 (patch)
tree52d61b6718a505b9086c95cbd392a671ff87fa1e /target/linux/ramips/image
parentf25326846bacdf9c78eb037d801f608e46683f54 (diff)
downloadmaster-187ad058-33678d2d30351fb803cc4efb4e2293987ee32689.tar.gz
master-187ad058-33678d2d30351fb803cc4efb4e2293987ee32689.tar.bz2
master-187ad058-33678d2d30351fb803cc4efb4e2293987ee32689.zip
ramips: fix Asus RT-N15 board support
Fix Asus RT-N15 flash partitions and make an image. Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29381 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 7f0ef00e46..24f59663cc 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -258,6 +258,17 @@ define Image/Build/Profile/Default
endef
endif
+
+define Image/Build/Profile/RTN15
+ $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
+endef
+
+ifeq ($(CONFIG_RALINK_RT288X),y)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/RTN15,$(1))
+endef
+endif
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef