aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:33 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:33 +0000
commit4ba599daa6be5b85eeb9909fcd7090fdd2cec841 (patch)
tree0ab9b9eb7d1a3a4a5cc9ba06e1f07ee9ad8f4f60 /target/linux/ramips/image
parentaddbde1976b932f70cf3d2f682e75b55cb1db9e9 (diff)
downloadmaster-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.tar.gz
master-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.tar.bz2
master-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.zip
ramips: Add support for Netgear EX2700
This patch adds support for the Netgear EX2700 and builds an approriate sysupgrade image. What's missing is the option to build a factory image flashable via the router's stock web interface, but this approach is hindered by the fact that u-boot operforms an additional integrity check, which expects a uImage header in the last 64 bytes of the "kernel" partition, which the bootloader expects to be 960k, a size exceeded by the standard OpenWrt kernel. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48698 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 27f349f619..a42f8b9dbc 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -913,6 +913,7 @@ endif
#
Image/Build/Profile/E1700=$(call BuildFirmware/UMedia/$(1),$(1),e1700,E1700,0x013326)
+Image/Build/Profile/EX2700=$(call BuildFirmware/Default4M/$(1),$(1),ex2700,EX2700)
Image/Build/Profile/MT7620a=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a,MT7620a)
Image/Build/Profile/MT7620a_MT7610e=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7610e,MT7620a_MT7610e)
Image/Build/Profile/MT7620a_MT7530=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7530,MT7620a_MT7530)
@@ -958,6 +959,7 @@ Image/Build/Profile/TINY-AC=$(call BuildFirmware/Default8M/$(1),$(1),tiny-ac,TIN
ifeq ($(SUBTARGET),mt7620)
define Image/Build/Profile/Default
$(call Image/Build/Profile/E1700,$(1))
+ $(call Image/Build/Profile/EX2700,$(1))
$(call Image/Build/Profile/MT7620a,$(1))
$(call Image/Build/Profile/MT7620a_MT7610e,$(1))
$(call Image/Build/Profile/MT7620a_MT7530,$(1))