aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit9157f620436a8383b13c30c0a26ad06b976b1a0b (patch)
tree768c585c31df15ffc89cd03480ce4558ea291ca0 /target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch
parent19deb0cf132ecd6cd1b4aa79fcc4462c698a38dd (diff)
downloadmaster-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.gz
master-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.bz2
master-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45711 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch')
-rw-r--r--[-rwxr-xr-x]target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch22
1 files changed, 8 insertions, 14 deletions
diff --git a/target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch b/target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch
index 5df95f40bb..b34581ed63 100755..100644
--- a/target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch
+++ b/target/linux/ramips/patches-3.18/0111-i2c-MIPS-add-mt7621-I2C-driver.patch
@@ -1,8 +1,6 @@
-Index: linux-3.18.9/drivers/i2c/busses/Kconfig
-===================================================================
---- linux-3.18.9.orig/drivers/i2c/busses/Kconfig 2015-03-23 15:00:11.730403938 +0800
-+++ linux-3.18.9/drivers/i2c/busses/Kconfig 2015-03-23 15:00:11.982403926 +0800
-@@ -714,6 +714,10 @@
+--- a/drivers/i2c/busses/Kconfig
++++ b/drivers/i2c/busses/Kconfig
+@@ -714,6 +714,10 @@ config I2C_RALINK
tristate "Ralink I2C Controller"
select OF_I2C
@@ -13,11 +11,9 @@ Index: linux-3.18.9/drivers/i2c/busses/Kconfig
config HAVE_S3C2410_I2C
bool
help
-Index: linux-3.18.9/drivers/i2c/busses/Makefile
-===================================================================
---- linux-3.18.9.orig/drivers/i2c/busses/Makefile 2015-03-23 15:00:11.730403938 +0800
-+++ linux-3.18.9/drivers/i2c/busses/Makefile 2015-03-23 15:00:11.982403926 +0800
-@@ -67,6 +67,7 @@
+--- a/drivers/i2c/busses/Makefile
++++ b/drivers/i2c/busses/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_I2C_PUV3) += i2c-puv3.o
obj-$(CONFIG_I2C_PXA) += i2c-pxa.o
obj-$(CONFIG_I2C_PXA_PCI) += i2c-pxa-pci.o
obj-$(CONFIG_I2C_RALINK) += i2c-ralink.o
@@ -25,10 +21,8 @@ Index: linux-3.18.9/drivers/i2c/busses/Makefile
obj-$(CONFIG_I2C_QUP) += i2c-qup.o
obj-$(CONFIG_I2C_RIIC) += i2c-riic.o
obj-$(CONFIG_I2C_RK3X) += i2c-rk3x.o
-Index: linux-3.18.9/drivers/i2c/busses/i2c-mt7621.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.18.9/drivers/i2c/busses/i2c-mt7621.c 2015-03-23 16:31:42.684747034 +0800
+--- /dev/null
++++ b/drivers/i2c/busses/i2c-mt7621.c
@@ -0,0 +1,303 @@
+/*
+ * drivers/i2c/busses/i2c-mt7621.c