aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-30 13:10:12 +0000
commita4c4a82647099a5d42afa8adb1e5eae1e0919797 (patch)
tree6297442313ccd9407a125bf42cd9d5e81e547fa2 /target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch
parent34747df14a33f589976259d7a6ef9831438ac94a (diff)
downloadmaster-187ad058-a4c4a82647099a5d42afa8adb1e5eae1e0919797.tar.gz
master-187ad058-a4c4a82647099a5d42afa8adb1e5eae1e0919797.tar.bz2
master-187ad058-a4c4a82647099a5d42afa8adb1e5eae1e0919797.zip
kernel: update linux 3.9 to 3.9.8
Includes memory allocation fixes as well as several networking fixes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch')
-rw-r--r--target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch b/target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch
index da94ee690a..16532c3ea9 100644
--- a/target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch
+++ b/target/linux/ramips/patches-3.9/0149-PCI-MIPS-adds-rt2880-pci-support.patch
@@ -13,11 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 283 insertions(+)
create mode 100644 arch/mips/pci/pci-rt2880.c
-diff --git a/arch/mips/pci/Makefile b/arch/mips/pci/Makefile
-index 2cb1d31..77974ba 100644
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
-@@ -41,6 +41,7 @@ obj-$(CONFIG_SIBYTE_BCM1x80) += pci-bcm1480.o pci-bcm1480ht.o
+@@ -41,6 +41,7 @@ obj-$(CONFIG_SIBYTE_BCM1x80) += pci-bcm1
obj-$(CONFIG_SNI_RM) += fixup-sni.o ops-sni.o
obj-$(CONFIG_LANTIQ) += fixup-lantiq.o
obj-$(CONFIG_PCI_LANTIQ) += pci-lantiq.o ops-lantiq.o
@@ -25,9 +23,6 @@ index 2cb1d31..77974ba 100644
obj-$(CONFIG_TANBAC_TB0219) += fixup-tb0219.o
obj-$(CONFIG_TANBAC_TB0226) += fixup-tb0226.o
obj-$(CONFIG_TANBAC_TB0287) += fixup-tb0287.o
-diff --git a/arch/mips/pci/pci-rt2880.c b/arch/mips/pci/pci-rt2880.c
-new file mode 100644
-index 0000000..e2c4730
--- /dev/null
+++ b/arch/mips/pci/pci-rt2880.c
@@ -0,0 +1,281 @@
@@ -312,8 +307,6 @@ index 0000000..e2c4730
+}
+
+arch_initcall(pcibios_init);
-diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
-index 3fe032c..c0ac93a 100644
--- a/arch/mips/ralink/Kconfig
+++ b/arch/mips/ralink/Kconfig
@@ -8,6 +8,7 @@ choice
@@ -324,6 +317,3 @@ index 3fe032c..c0ac93a 100644
config SOC_RT305X
bool "RT305x"
---
-1.7.10.4
-