aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
commit83749d6607929e6a2345d112bede06e74d077e58 (patch)
tree7cb1f40d59129ce8f038f64156463f479f7822a1 /target/linux/rdc-2.6/Makefile
parent7648faea5484d511aff3a8730c9cfec1917c7b3c (diff)
downloadmaster-187ad058-83749d6607929e6a2345d112bede06e74d077e58.tar.gz
master-187ad058-83749d6607929e6a2345d112bede06e74d077e58.tar.bz2
master-187ad058-83749d6607929e6a2345d112bede06e74d077e58.zip
Merge preliminary rdc-2.6 support (Airlink101 AR525W)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc-2.6/Makefile')
-rw-r--r--target/linux/rdc-2.6/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
new file mode 100644
index 0000000000..59f02b3340
--- /dev/null
+++ b/target/linux/rdc-2.6/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+ @$(CP) config $(LINUX_DIR)/.config
+ touch $@