aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
committerMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
commit845092569c227454f28d77e647d386ab7cc1419f (patch)
treeefab142ef89b35ce42e8a79e028eff15be362af8 /target/linux/s3c24xx/Makefile
parentd565bb20de4a9dec01f2f4c0f62be55eb61435a9 (diff)
downloadmaster-187ad058-845092569c227454f28d77e647d386ab7cc1419f.tar.gz
master-187ad058-845092569c227454f28d77e647d386ab7cc1419f.tar.bz2
master-187ad058-845092569c227454f28d77e647d386ab7cc1419f.zip
add support for target 3c24xx (more known as Openmoko GTA02 "Freerunner") and merge it with the openmoko-target and the work Michael Buesch <mb> did
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13609 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/s3c24xx/Makefile')
-rwxr-xr-xtarget/linux/s3c24xx/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/Makefile b/target/linux/s3c24xx/Makefile
new file mode 100755
index 0000000000..66496fc9f8
--- /dev/null
+++ b/target/linux/s3c24xx/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=s3c24xx
+BOARDNAME:=s3c24xx
+FEATURES:=jffs2
+
+LINUX_VERSION:=2.6.26
+
+DEVICE_TYPE=phone
+
+define Target/Description
+ OpenMoko gta02
+endef
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += xglamo enlightenment
+
+$(eval $(call BuildTarget))