aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 10:44:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 10:44:44 +0000
commit81de7a14613eac419d9cdc7a2082e344d2bcbcbb (patch)
tree2b8ec744fe428a1d38224870b0c4ab859394b91e /target/linux/sibyte/image
parent787ae50e419115c9d4a96ee146165ef05564276d (diff)
downloadmaster-187ad058-81de7a14613eac419d9cdc7a2082e344d2bcbcbb.tar.gz
master-187ad058-81de7a14613eac419d9cdc7a2082e344d2bcbcbb.tar.bz2
master-187ad058-81de7a14613eac419d9cdc7a2082e344d2bcbcbb.zip
sibyte: moved to targets feed
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45080 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sibyte/image')
-rw-r--r--target/linux/sibyte/image/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/target/linux/sibyte/image/Makefile b/target/linux/sibyte/image/Makefile
deleted file mode 100644
index 9a25ace61f..0000000000
--- a/target/linux/sibyte/image/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# Copyright (C) 2007-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/BuildKernel
- cp $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
-# uImage
- dd if=$(KDIR)/vmlinux of=$(KDIR)/$(IMG_PREFIX)-vmlinux bs=64k conv=sync
- mkimage -A mips -O linux -T kernel -a 0x80100000 -C none -e \
- 0x80100000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/$(IMG_PREFIX)-vmlinux $(BIN_DIR)/$(IMG_PREFIX)-uImage
-endef
-
-define Image/Build
- $(call Image/Build/$(1),$(1))
-endef
-
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=65536 conv=sync
-endef
-
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
- $(call Image/Build/slug,$(1))
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=131072 conv=sync
-endef
-
-$(eval $(call BuildImage))