aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-07-28 12:36:09 +0000
committerNicolas Thill <nico@openwrt.org>2008-07-28 12:36:09 +0000
commit5b7be7a2bb6d6f5d3eb79877c32f63a55865729d (patch)
treeeb0f838c740c0005e5c3536585d184f05d5b8ca7 /target/linux/uml
parent1a1bdc1fe96a044c7204a1518a894182f224110e (diff)
downloadmaster-187ad058-5b7be7a2bb6d6f5d3eb79877c32f63a55865729d.tar.gz
master-187ad058-5b7be7a2bb6d6f5d3eb79877c32f63a55865729d.tar.bz2
master-187ad058-5b7be7a2bb6d6f5d3eb79877c32f63a55865729d.zip
add a fix to prevent startup crashes on i386 when built with gcc < 4.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11969 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml')
-rw-r--r--target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..48cffffcd4
--- /dev/null
+++ b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,13 @@
+Index: linux-2.6.26/arch/um/Makefile-i386
+===================================================================
+--- linux-2.6.26.orig/arch/um/Makefile-i386 2008-07-28 13:43:40.412036547 +0200
++++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+@@ -35,7 +35,7 @@
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0430 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+