aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-07 12:23:35 +0000
commitb3160a58e8dec8780106b2cd86eda3a3d79c0903 (patch)
tree72c2507d12b087fae093eba5588478966a983a50 /target/linux/x86_64/Makefile
parent9c5efa1ea2f7d4e6fdd20d1c05258993e3653287 (diff)
downloadmaster-187ad058-b3160a58e8dec8780106b2cd86eda3a3d79c0903.tar.gz
master-187ad058-b3160a58e8dec8780106b2cd86eda3a3d79c0903.tar.bz2
master-187ad058-b3160a58e8dec8780106b2cd86eda3a3d79c0903.zip
add x86_64 target support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39208 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86_64/Makefile')
-rw-r--r--target/linux/x86_64/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/x86_64/Makefile b/target/linux/x86_64/Makefile
new file mode 100644
index 0000000000..09913f2689
--- /dev/null
+++ b/target/linux/x86_64/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=x86_64
+BOARD:=x86_64
+BOARDNAME:=x86_64
+FEATURES:=ext4 vdi vmdk targz
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+LINUX_VERSION:=3.10.24
+
+KERNELNAME:=bzImage
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-e1000
+
+$(eval $(call BuildTarget))