aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
commit795063e4bd943a6f8b10d4ed11ddce8aad604771 (patch)
treebd27c2604891a5f0871e47c5a5027278ce4b9029 /target/linux/x86_64/image
parenta12f75fc15f858afc69fcf64d8bc8fc526bc7fdc (diff)
downloadmaster-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.tar.gz
master-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.tar.bz2
master-187ad058-795063e4bd943a6f8b10d4ed11ddce8aad604771.zip
x86: make x86_64 a subtarget instead of a standalone target
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45115 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86_64/image')
-rw-r--r--target/linux/x86_64/image/Makefile220
-rwxr-xr-xtarget/linux/x86_64/image/gen_image_generic.sh39
-rw-r--r--target/linux/x86_64/image/grub-early.cfg1
-rw-r--r--target/linux/x86_64/image/grub-iso.cfg10
-rw-r--r--target/linux/x86_64/image/grub.cfg13
5 files changed, 0 insertions, 283 deletions
diff --git a/target/linux/x86_64/image/Makefile b/target/linux/x86_64/image/Makefile
deleted file mode 100644
index cd80bb1de8..0000000000
--- a/target/linux/x86_64/image/Makefile
+++ /dev/null
@@ -1,220 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-export PATH=$(TARGET_PATH):/sbin
-
-GRUB2_MODULES = biosdisk boot chain configfile ext2 linux ls part_msdos reboot serial vga
-GRUB2_MODULES_ISO = biosdisk boot chain configfile iso9660 linux ls part_msdos reboot serial vga
-GRUB_TERMINALS =
-GRUB_SERIAL_CONFIG =
-GRUB_TERMINAL_CONFIG =
-GRUB_CONSOLE_CMDLINE =
-
-USE_ATKBD = generic kvm_guest
-
-ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_64_$(subtarget)))),)
- GRUB2_MODULES += at_keyboard
- GRUB2_MODULES_ISO += at_keyboard
-endif
-
-ifneq ($(CONFIG_GRUB_CONSOLE),)
- GRUB_CONSOLE_CMDLINE += console=tty0
- GRUB_TERMINALS += console
-endif
-
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
-
-ifneq ($(GRUB_SERIAL),)
- GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
- GRUB_TERMINALS += serial
-endif
-
-ifneq ($(GRUB_TERMINALS),)
- GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
-endif
-
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
-ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
-ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
-
-GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
-
-ifneq ($(CONFIG_GRUB_IMAGES),)
-
- BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
-
- define Image/cmdline/ext4
- root=$(ROOTPART) rootfstype=ext4 rootwait
- endef
-
- define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
- endef
-
- define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
- endef
-
- define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
- endef
-
- define Image/Build/grub2
- # left here because the image builder doesnt need these
- $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
- $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
- grub-mkimage \
- -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
- -o $(KDIR)/grub2/core.img \
- -O i386-pc \
- -c ./grub-early.cfg \
- $(GRUB2_MODULES)
- $(CP) $(STAGING_DIR_HOST)/lib/grub/i386-pc/*.img $(KDIR)/grub2/
- echo '(hd0) $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img' > $(KDIR)/grub2/device.map
- sed \
- -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
- -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
- -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
- -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
- ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
- PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" ./gen_image_generic.sh \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1) \
- 256
- grub-bios-setup \
- --device-map="$(KDIR)/grub2/device.map" \
- -d "$(KDIR)/grub2" \
- -r "hd0,msdos1" \
- "$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img"
- $(call Image/Build/grub/$(1))
- endef
-endif
-
-ROOTDELAY=10
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
-define Image/Build/iso
- $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
- $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
- grub-mkimage \
- -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
- -o $(KDIR)/grub2/eltorito.img \
- -O i386-pc \
- -c ./grub-early.cfg \
- $(GRUB2_MODULES_ISO)
- cat \
- $(STAGING_DIR_HOST)/lib/grub/i386-pc/cdboot.img \
- $(KDIR)/grub2/eltorito.img \
- > $(KDIR)/root.grub/boot/grub/eltorito.img
- sed \
- -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
- -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
- -e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
- -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
- ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
- $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
- mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
- -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
-endef
-
-ifneq ($(CONFIG_VDI_IMAGES),)
- define Image/Build/vdi
- # left here because the image builder doesnt need these
- ifeq ($(1),ext4)
- rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
- qemu-img convert -f raw -O vdi \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- # XXX: VBoxManage insists on setting perms to 0600
- chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
- endif
- endef
-endif
-
-ifneq ($(CONFIG_VMDK_IMAGES),)
- define Image/Build/vmdk
- # left here because the image builder doesnt need these
- ifeq ($(1),ext4)
- rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
- qemu-img convert -f raw -O vmdk -o adapter_type=lsilogic \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
- rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1)-esxi.vmdk || true
- qemu-img convert -f raw -O vmdk -o adapter_type=lsilogic,subformat=monolithicFlat \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1)-esxi.vmdk
- endif
- endef
-endif
-
-define Image/Build/gzip
- gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
- gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
-endef
-
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
- define Image/Build/gzip/ext4
- $(call Image/Build/gzip,ext4)
- endef
- ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
- define Image/Build/gzip/squashfs
- $(call Image/Build/gzip,squashfs)
- endef
- define Image/Build/gzip/jffs2-64k
- $(call Image/Build/gzip,jffs2-64k)
- endef
- define Image/Build/gzip/jffs2-128k
- $(call Image/Build/gzip,jffs2-128k)
- endef
- endif
-endif
-
-define Image/BuildKernel
- $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-endef
-
-define Image/Prepare
- $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
- $(call Image/Prepare/bootscript)
- $(call Image/Prepare/grub2)
-endef
-
-define Image/Build/Initramfs
- $(CP) $(KDIR)/bzImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-ramfs.bzImage
-endef
-
-define Image/Build
- $(call Image/Build/$(1))
- $(call Image/Build/bootscript,$(1))
- ifneq ($(1),iso)
- $(call Image/Build/grub2,$(1))
- $(call Image/Build/vdi,$(1))
- $(call Image/Build/vmdk,$(1))
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
- else
- $(CP) $(KDIR)/root.iso $(BIN_DIR)/$(IMG_PREFIX).iso
- endif
- $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
- $(call Image/Build/gzip/$(1))
- $(call Image/Build/Profile/$(PROFILE),$(1))
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- $(call Image/Build/Initramfs)
-endif
-endef
-
-$(eval $(call BuildImage))
-
-$(eval $(call RequireCommand,qemu-img, \
- Please install qemu-img (package qemu-utils in Ubuntu/Debian). \
-))
diff --git a/target/linux/x86_64/image/gen_image_generic.sh b/target/linux/x86_64/image/gen_image_generic.sh
deleted file mode 100755
index 711c755cf9..0000000000
--- a/target/linux/x86_64/image/gen_image_generic.sh
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/usr/bin/env bash
-# Copyright (C) 2006-2012 OpenWrt.org
-set -x
-[ $# -eq 5 -o $# -eq 6 ] || {
- echo "SYNTAX: $0 <file> <kernel size> <kernel directory> <rootfs size> <rootfs image> [<align>]"
- exit 1
-}
-
-OUTPUT="$1"
-KERNELSIZE="$2"
-KERNELDIR="$3"
-ROOTFSSIZE="$4"
-ROOTFSIMAGE="$5"
-ALIGN="$6"
-
-rm -f "$OUTPUT"
-
-head=16
-sect=63
-cyl=$(( ($KERNELSIZE + $ROOTFSSIZE) * 1024 * 1024 / ($head * $sect * 512)))
-
-# create partition table
-set `ptgen -o "$OUTPUT" -h $head -s $sect -p ${KERNELSIZE}m -p ${ROOTFSSIZE}m ${ALIGN:+-l $ALIGN} ${SIGNATURE:+-S 0x$SIGNATURE}`
-
-KERNELOFFSET="$(($1 / 512))"
-KERNELSIZE="$(($2 / 512))"
-ROOTFSOFFSET="$(($3 / 512))"
-ROOTFSSIZE="$(($4 / 512))"
-
-BLOCKS="$((($KERNELSIZE / 2) - 1))"
-
-[ -n "$PADDING" ] && dd if=/dev/zero of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc count="$ROOTFSSIZE"
-dd if="$ROOTFSIMAGE" of="$OUTPUT" bs=512 seek="$ROOTFSOFFSET" conv=notrunc
-
-[ -n "$NOGRUB" ] && exit 0
-
-genext2fs -d "$KERNELDIR" -b "$BLOCKS" "$OUTPUT.kernel"
-dd if="$OUTPUT.kernel" of="$OUTPUT" bs=512 seek="$KERNELOFFSET" conv=notrunc
-rm -f "$OUTPUT.kernel"
diff --git a/target/linux/x86_64/image/grub-early.cfg b/target/linux/x86_64/image/grub-early.cfg
deleted file mode 100644
index 4a5b5a6092..0000000000
--- a/target/linux/x86_64/image/grub-early.cfg
+++ /dev/null
@@ -1 +0,0 @@
-configfile (hd0,msdos1)/boot/grub/grub.cfg
diff --git a/target/linux/x86_64/image/grub-iso.cfg b/target/linux/x86_64/image/grub-iso.cfg
deleted file mode 100644
index 3d47a95a4b..0000000000
--- a/target/linux/x86_64/image/grub-iso.cfg
+++ /dev/null
@@ -1,10 +0,0 @@
-@SERIAL_CONFIG@
-@TERMINAL_CONFIG@
-
-set default="0"
-set timeout="@TIMEOUT@"
-set root='(cd)'
-
-menuentry "OpenWrt" {
- linux /boot/vmlinuz @CMDLINE@ noinitrd
-}
diff --git a/target/linux/x86_64/image/grub.cfg b/target/linux/x86_64/image/grub.cfg
deleted file mode 100644
index 33b9d0b1aa..0000000000
--- a/target/linux/x86_64/image/grub.cfg
+++ /dev/null
@@ -1,13 +0,0 @@
-@SERIAL_CONFIG@
-@TERMINAL_CONFIG@
-
-set default="0"
-set timeout="@TIMEOUT@"
-set root='(hd0,msdos1)'
-
-menuentry "OpenWrt" {
- linux /boot/vmlinuz @CMDLINE@ noinitrd
-}
-menuentry "OpenWrt (failsafe)" {
- linux /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd
-}