aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 10:06:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 10:06:40 +0000
commit7c11754589fca13abb7fc73e73c1e53312e92bad (patch)
tree5afb03e6ae9de959d9c177916c9c0cb8dd0c437d /target/linux/x86_64
parentdadb724fb7fa20a91758f3f4536aeb40ff3a4ece (diff)
downloadmaster-187ad058-7c11754589fca13abb7fc73e73c1e53312e92bad.tar.gz
master-187ad058-7c11754589fca13abb7fc73e73c1e53312e92bad.tar.bz2
master-187ad058-7c11754589fca13abb7fc73e73c1e53312e92bad.zip
x86_64: fix PARTUUID format with leading zeros
Otherwise the root device won't be found in 1/16 of the generated images (whenever the signature starts with a zero digit). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44959 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86_64')
-rw-r--r--target/linux/x86_64/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86_64/image/Makefile b/target/linux/x86_64/image/Makefile
index e8d9ac1158..cd80bb1de8 100644
--- a/target/linux/x86_64/image/Makefile
+++ b/target/linux/x86_64/image/Makefile
@@ -40,7 +40,7 @@ ifneq ($(GRUB_TERMINALS),)
GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
endif
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%02x"')
+SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)