aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86_64
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-19 17:46:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-19 17:46:37 +0000
commitfc13c5df1c7c9d4daae9a7666aaf7a4d699ade10 (patch)
treeb1c0f1faf148c35e74441283c7cc8d2c66653490 /target/linux/x86_64
parent02ef17870cf69c051879020bbba6c03db322351e (diff)
downloadmaster-187ad058-fc13c5df1c7c9d4daae9a7666aaf7a4d699ade10.tar.gz
master-187ad058-fc13c5df1c7c9d4daae9a7666aaf7a4d699ade10.tar.bz2
master-187ad058-fc13c5df1c7c9d4daae9a7666aaf7a4d699ade10.zip
x86_64: use default block2mtd timeout of 5s
If the underlying block device is a USB device it might require some time to settle, observed when booting a squashfs image from sd card on an Alix APU board. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42966 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86_64')
-rw-r--r--target/linux/x86_64/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86_64/image/Makefile b/target/linux/x86_64/image/Makefile
index aacdab0ff6..e8d9ac1158 100644
--- a/target/linux/x86_64/image/Makefile
+++ b/target/linux/x86_64/image/Makefile
@@ -55,15 +55,15 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
endef
define Image/Build/grub2