aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-29 10:34:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-29 10:34:19 +0000
commit0e14d8982c412826e1a2d61a4e94bf9a6703f8dc (patch)
tree0627318232106b19fc8122b25937751aabaeffce /target
parenteba73f4bbaea81ce7760d701037c7622c9aa49f0 (diff)
downloadmaster-187ad058-0e14d8982c412826e1a2d61a4e94bf9a6703f8dc.tar.gz
master-187ad058-0e14d8982c412826e1a2d61a4e94bf9a6703f8dc.tar.bz2
master-187ad058-0e14d8982c412826e1a2d61a4e94bf9a6703f8dc.zip
[ar71xx] generate firmware image for the Ubiquiti RouterStation board (based on a patch by Jonas <jmajau at ubnt.com>)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13758 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d49f16bafa..0443995859 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -59,6 +59,17 @@ define Image/Build/MyLoader
$(call imgname,$(1),$(2)).img
endef
+define Image/Build/UBNT
+ cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+ -$(STAGING_DIR_HOST)/bin/mkfwimage \
+ -B $(4) -v $(5).ar7100.OpenWrt \
+ -k $(KDIR)/vmlinux-$(2).bin.lzma \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
+endef
+
define Image/Build/Template/Compex
$(call Image/Build/MyLoader,$(1),$(2))
endef
@@ -75,6 +86,14 @@ define Image/Build/Template/AP81/squashfs
$(call Image/Build/Template/AP81,squashfs,$(1),$(2),$(3))
endef
+define Image/Build/Template/UBNT
+ $(call Image/Build/UBNT,$(1),$(2),$(3),$(4),$(5))
+endef
+
+define Image/Build/Template/UBNT/squashfs
+ $(call Image/Build/Template/UBNT,squashfs,$(1),$(2),$(3))
+endef
+
define Image/Build/Profile/WP543
$(call Image/Build/Template/Compex/$(1),wp543)
endef
@@ -91,6 +110,10 @@ define Image/Build/Profile/TEW652BRP
$(call Image/Build/Template/AP81/$(1),tew-652brp,board=TEW-632BRP,"AP81-AR9130-RT-080609-05")
endef
+define Image/Build/Profile/UBNTRS
+ $(call Image/Build/Template/UBNT,$(1),rs,board=UBNT-RS,RS,RSx)
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -102,6 +125,7 @@ define Image/Build
$(call Image/Build/Profile/DIR615C1,$(1))
$(call Image/Build/Profile/TEW632BRP,$(1))
$(call Image/Build/Profile/TEW652BRP,$(1))
+ $(call Image/Build/Profile/UBNTRS,$(1))
$(call Image/Build/Profile/WP543,$(1))
endef