aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2008-07-25 03:55:21 +0000
committerTravis Kemen <thepeople@openwrt.org>2008-07-25 03:55:21 +0000
commit0ead72668a589118360bfe8dc34fd296e2cb8469 (patch)
tree71d0910bca6cdaadf0f24c591bcc835ded3e3c37 /target
parent4de53e6237d9535216a3f7a97a5a622be2480fd6 (diff)
downloadmaster-187ad058-0ead72668a589118360bfe8dc34fd296e2cb8469.tar.gz
master-187ad058-0ead72668a589118360bfe8dc34fd296e2cb8469.tar.bz2
master-187ad058-0ead72668a589118360bfe8dc34fd296e2cb8469.zip
Use mkfwimage from athero.openwrt.net with modification for XS2 devices. Add back in ubiquiti image generation.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11920 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/atheros/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index d50cae5049..17b18deeed 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -22,6 +22,16 @@ endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+
+ $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -v XS2.ar2316.OpenWRT \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
+ $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -v XS5.ar2313.OpenWRT \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \
+ -s 0xBE030000
endef
$(eval $(call BuildImage))