aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-16 12:29:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-16 12:29:11 +0000
commit1a7f8acef6c0810762ed6c76ea287607fee9d778 (patch)
treed8b72f7f5406814d374f3fad0d7f16b4bfeb899a /target
parent727029948efce84626e2921c3a5765c9061a50c5 (diff)
downloadmaster-187ad058-1a7f8acef6c0810762ed6c76ea287607fee9d778.tar.gz
master-187ad058-1a7f8acef6c0810762ed6c76ea287607fee9d778.tar.bz2
master-187ad058-1a7f8acef6c0810762ed6c76ea287607fee9d778.zip
[brcm63xx] add the CFE offset command line option to the imagetag utility, closes (#4366)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14896 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 250cc8236d..b6ef968294 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -42,7 +42,7 @@ define Image/Build/CFEAGPF
$(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
-o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
-b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
- -v 8 -m IMAGE -k 131072
+ -v 8 -m IMAGE -k 131072 -n $(4)
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
endef
@@ -114,7 +114,7 @@ define Image/Build
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
- $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358)
+ $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000)
endef
$(eval $(call BuildImage))