aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-10 09:06:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-10 09:06:10 +0000
commit2a6e03d7adeb8eb4794bd0639005cd70955ed311 (patch)
treea001762136668802d18158fd25baf479e56e6f44 /target
parentf10e6fd9af01ea8281cc8a20d2722250851673b2 (diff)
downloadmaster-187ad058-2a6e03d7adeb8eb4794bd0639005cd70955ed311.tar.gz
master-187ad058-2a6e03d7adeb8eb4794bd0639005cd70955ed311.tar.bz2
master-187ad058-2a6e03d7adeb8eb4794bd0639005cd70955ed311.zip
atheros: trailing statements fixes
Move trailing statements to next line with indentation as suggested by checkpatch. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41092 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/atheros/patches-3.10/100-board.patch5
-rw-r--r--target/linux/atheros/patches-3.10/101-early-printk-support.patch8
-rw-r--r--target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch8
-rw-r--r--target/linux/atheros/patches-3.10/230-3_10-updates.patch2
4 files changed, 14 insertions, 9 deletions
diff --git a/target/linux/atheros/patches-3.10/100-board.patch b/target/linux/atheros/patches-3.10/100-board.patch
index 33c7ce56da..07b8145b95 100644
--- a/target/linux/atheros/patches-3.10/100-board.patch
+++ b/target/linux/atheros/patches-3.10/100-board.patch
@@ -84,7 +84,7 @@
+obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
--- /dev/null
+++ b/arch/mips/ar231x/board.c
-@@ -0,0 +1,260 @@
+@@ -0,0 +1,261 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -297,7 +297,8 @@
+ar231x_halt(void)
+{
+ local_irq_disable();
-+ while (1);
++ while (1)
++ ;
+}
+
+void __init
diff --git a/target/linux/atheros/patches-3.10/101-early-printk-support.patch b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
index 2346e24918..3daa0117f7 100644
--- a/target/linux/atheros/patches-3.10/101-early-printk-support.patch
+++ b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
@@ -1,6 +1,6 @@
--- /dev/null
+++ b/arch/mips/ar231x/early_printk.c
-@@ -0,0 +1,44 @@
+@@ -0,0 +1,46 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -40,9 +40,11 @@
+ base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
+ }
+
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++ ;
+ prom_uart_wr(base, UART_TX, ch);
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++ ;
+}
+
--- a/arch/mips/ar231x/Makefile
diff --git a/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch b/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
index 1fc4eb49d3..b283e310dc 100644
--- a/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
+++ b/target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
@@ -32,7 +32,7 @@
+obj-$(CONFIG_NET_VENDOR_AR231X) += ar231x.o
--- /dev/null
+++ b/drivers/net/ethernet/ar231x/ar231x.c
-@@ -0,0 +1,1255 @@
+@@ -0,0 +1,1257 @@
+/*
+ * ar231x.c: Linux driver for the Atheros AR231x Ethernet device.
+ *
@@ -1208,7 +1208,8 @@
+ volatile ETHERNET_STRUCT *ethernet = sp->phy_regs;
+
+ ethernet->mii_addr = MII_ADDR(phy_addr, regnum);
-+ while (ethernet->mii_addr & MII_ADDR_BUSY);
++ while (ethernet->mii_addr & MII_ADDR_BUSY)
++ ;
+ return ethernet->mii_data >> MII_DATA_SHIFT;
+}
+
@@ -1219,7 +1220,8 @@
+ struct ar231x_private *sp = netdev_priv(dev);
+ volatile ETHERNET_STRUCT *ethernet = sp->phy_regs;
+
-+ while (ethernet->mii_addr & MII_ADDR_BUSY);
++ while (ethernet->mii_addr & MII_ADDR_BUSY)
++ ;
+ ethernet->mii_data = value << MII_DATA_SHIFT;
+ ethernet->mii_addr = MII_ADDR(phy_addr, regnum) | MII_ADDR_WRITE;
+
diff --git a/target/linux/atheros/patches-3.10/230-3_10-updates.patch b/target/linux/atheros/patches-3.10/230-3_10-updates.patch
index 8e4db175fe..f1adf82461 100644
--- a/target/linux/atheros/patches-3.10/230-3_10-updates.patch
+++ b/target/linux/atheros/patches-3.10/230-3_10-updates.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/ethernet/ar231x/ar231x.c
+++ b/drivers/net/ethernet/ar231x/ar231x.c
-@@ -1272,7 +1272,7 @@ static int ar231x_mdiobus_probe(struct n
+@@ -1274,7 +1274,7 @@ static int ar231x_mdiobus_probe(struct n
BUG_ON(!phydev);
BUG_ON(phydev->attached_dev);