aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-08 13:35:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-08 13:35:25 +0000
commit3d21246af054fd9ba0f9e4d5f7bd8547101105a0 (patch)
treeace445449dd4f1d5dc8dfbd0eff3db83cb5777b4 /target
parent4cbf5257ab95c038e218880bd218e85225273ba8 (diff)
downloadmaster-187ad058-3d21246af054fd9ba0f9e4d5f7bd8547101105a0.tar.gz
master-187ad058-3d21246af054fd9ba0f9e4d5f7bd8547101105a0.tar.bz2
master-187ad058-3d21246af054fd9ba0f9e4d5f7bd8547101105a0.zip
ar71xx: add missing flash partition for the DIR-825
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19075 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c5
-rw-r--r--target/linux/ar71xx/image/Makefile2
2 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c
index 7762b5cdc5..80ab330844 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c
@@ -68,6 +68,11 @@ static struct mtd_partition dir825b1_partitions[] = {
.offset = 0x660000,
.size = 0x010000,
.mask_flags = MTD_WRITEABLE,
+ } , {
+ .name = "unknown",
+ .offset = 0x670000,
+ .size = 0x190000,
+ .mask_flags = MTD_WRITEABLE,
}
};
#endif /* CONFIG_MTD_PARTITIONS */
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 94920a8030..746f52576e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -77,7 +77,7 @@ define Image/Build/WRT400N
fi; fi
endef
-dir825b1_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),5184k(rootfs),64k(caldata)ro,6208k@0x50000(firmware)
+dir825b1_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),5184k(rootfs),64k(caldata)ro,1600k(unknown)ro,6208k@0x50000(firmware)
define Image/Build/DIR825B1
$(call PatchKernelLzma,$(2),$(3) $(dir825b1_mtdlayout))
$(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(call imgname,$(1),$(2)).bin)