aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-06-05 21:25:03 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-06-05 21:25:03 +0000
commit42acb527796fb697dc99d167031c05a70542e932 (patch)
treedbfa33988e24d84d34d75c8b87db9328b9fec869 /target
parent431f863e5eda392580e2d7916973b27fc0a81f15 (diff)
downloadmaster-187ad058-42acb527796fb697dc99d167031c05a70542e932.tar.gz
master-187ad058-42acb527796fb697dc99d167031c05a70542e932.tar.bz2
master-187ad058-42acb527796fb697dc99d167031c05a70542e932.zip
brcm47xx: add mips74k subtarget for newer devices
All new devices (with MIPS 74K CPU) are based on BCMA SoC and have Ethernet core supported by bgmac. Create a new subtarget to generate optimized builds. This is just a beginning, further tweaks (like kernel configuration) are still possible. This decreases default root.squashfs by ~128 kB. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41025 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk19
-rw-r--r--target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk18
-rw-r--r--target/linux/brcm47xx/mips74k/target.mk6
6 files changed, 82 insertions, 1 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index fa5d21bbe9..17a9e314bf 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=mipsel
BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
FEATURES:=squashfs usb pcmcia low_mem
-SUBTARGETS:=generic
+SUBTARGETS:=generic mips74k
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
LINUX_VERSION:=3.10.36
diff --git a/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..7d3c6a7a52
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-b43
+ NAME:=Broadcom SoC, BCM43xx WiFi (b43)
+ PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-mips74k-b43/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and b43
+ driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-b43))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk b/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
new file mode 100644
index 0000000000..2d09cd2856
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-brcmsmac
+ NAME:=Broadcom SoC, BCM43xx WiFi (brcmsmac)
+ PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-mips74k-brcmsmac/Description
+ Package set for devices with BCM43xx WiFi including mac80211 and
+ brcmsmac driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-brcmsmac))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
new file mode 100644
index 0000000000..37063acaae
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-wl
+ NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
+ PACKAGES:=kmod-bgmac -wpad-mini kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-mips74k-wl/Description
+ Package set for devices with BCM43xx WiFi including proprietary (and
+ closed source) driver "wl".
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-wl))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
new file mode 100644
index 0000000000..bfe3719247
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-none
+ NAME:=Broadcom SoC, No WiFi
+ PACKAGES:=kmod-bgmac -wpad-mini
+endef
+
+define Profile/Broadcom-mips74k-none/Description
+ Package set for devices without a WiFi.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-none))
+
diff --git a/target/linux/brcm47xx/mips74k/target.mk b/target/linux/brcm47xx/mips74k/target.mk
new file mode 100644
index 0000000000..ab7af28b67
--- /dev/null
+++ b/target/linux/brcm47xx/mips74k/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=MIPS 74K
+
+define Target/Description
+ Build firmware for Broadcom BCM47xx and BCM53xx devices with
+ MIPS 74K CPU.
+endef