aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-12-15 08:32:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-12-15 08:32:04 +0000
commit432f4405507c4c9663403da8140bc795187198d4 (patch)
tree8584ad486bf2debe24c24e2c859afb596ad15263 /target
parentc26365de6706a01e64fc6c89317102a9bcc5bc7f (diff)
downloadmaster-187ad058-432f4405507c4c9663403da8140bc795187198d4.tar.gz
master-187ad058-432f4405507c4c9663403da8140bc795187198d4.tar.bz2
master-187ad058-432f4405507c4c9663403da8140bc795187198d4.zip
[ar71xx] tew-632brp: use LZMA compressed uImage
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13645 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c14
-rw-r--r--target/linux/ar71xx/image/Makefile10
2 files changed, 12 insertions, 12 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
index c162913903..c736b79516 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
@@ -34,20 +34,20 @@ static struct mtd_partition tew_632brp_partitions[] = {
} , {
.name = "kernel",
.offset = 0x030000,
- .size = 0x100000,
+ .size = 0x0c0000,
} , {
.name = "rootfs",
- .offset = 0x130000,
- .size = 0x2b0000,
- } , {
- .name = "firmware",
- .offset = 0x030000,
- .size = 0x3b0000,
+ .offset = 0x0f0000,
+ .size = 0x2f0000,
} , {
.name = "art",
.offset = 0x3e0000,
.size = 0x020000,
.mask_flags = MTD_WRITEABLE,
+ } , {
+ .name = "firmware",
+ .offset = 0x030000,
+ .size = 0x3b0000,
}
};
#endif /* CONFIG_MTD_PARTITIONS */
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a9c7dd679f..3950b0b52e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -39,14 +39,14 @@ endef
define Image/Build/AP81
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
- gzip -9 -c $(KDIR)/vmlinux-$(2) > $(KDIR)/vmlinux-$(2).bin.gz
- mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
0x80060000 \
-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux-$(2).bin.gz $(KDIR)/vmlinux-$(2).uImage
+ -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage
( \
- dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=2752k conv=sync; \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
) > $(call imgname,$(1),$(2)).bin
cp $(call imgname,$(1),$(2)).bin $(call imgname,$(1),$(2)).webui
echo -n $(4) >> $(call imgname,$(1),$(2)).webui