aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-21 21:07:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-21 21:07:10 +0000
commit6c40f8dfeaa73960b67a253de6f5aaef5b8b9f73 (patch)
treeed90335926fe51f5eb82901c06336ed55f57b93b /target
parent197e1e00cb643034cead9467cc5924fe1cb8b38d (diff)
downloadmaster-187ad058-6c40f8dfeaa73960b67a253de6f5aaef5b8b9f73.tar.gz
master-187ad058-6c40f8dfeaa73960b67a253de6f5aaef5b8b9f73.tar.bz2
master-187ad058-6c40f8dfeaa73960b67a253de6f5aaef5b8b9f73.zip
sync broadcom image build with whiterussian
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2216 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/image/brcm/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index 23072bde9b..73d236a2d5 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -15,7 +15,8 @@ ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux
cat $^ | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $@ || (rm -f $@ && false)
-$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma compile
+$(KDIR)/loader.tmp.gz: compile
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx: $(KDIR)/vmlinux.lzma
endif
ifeq ($(FS),jffs2-8MB)
@@ -42,11 +43,22 @@ endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+ifeq ($(FS),squashfs)
+$(BIN_DIR)/openwrt-wap54g-$(FSNAME).trx: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ cp $< $@
+ echo -ne '\x01' >> $@
+
+install: $(BIN_DIR)/openwrt-wap54g-$(FSNAME).trx
+endif
+
ifneq ($(FS),jffs2-8MB)
$(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
$(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
-install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin
+$(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+
+install: $(BIN_DIR)/openwrt-wrt54g-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(FSNAME).bin
endif
ifneq ($(FS),jffs2-4MB)