aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-03-15 14:30:08 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-03-15 14:30:08 +0000
commit7388714b9cb9d9be39f5aa7350d7d4f5eb8d69d9 (patch)
treedffb92015dcb499b8b0e54f58ed68c6bb7b02c65 /target
parent162ce435381635eb2a1d41d78f9b6479d7fd4c2e (diff)
downloadmaster-187ad058-7388714b9cb9d9be39f5aa7350d7d4f5eb8d69d9.tar.gz
master-187ad058-7388714b9cb9d9be39f5aa7350d7d4f5eb8d69d9.tar.bz2
master-187ad058-7388714b9cb9d9be39f5aa7350d7d4f5eb8d69d9.zip
[ar71xx] preliminary support for the Atheros AP81 refrence board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14888 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/config-2.6.281
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c22
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/prom.c7
-rw-r--r--target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h1
6 files changed, 34 insertions, 2 deletions
diff --git a/target/linux/ar71xx/config-2.6.28 b/target/linux/ar71xx/config-2.6.28
index f885d6df08..1015c8dcc9 100644
--- a/target/linux/ar71xx/config-2.6.28
+++ b/target/linux/ar71xx/config-2.6.28
@@ -6,6 +6,7 @@ CONFIG_AG71XX=y
CONFIG_AG71XX_AR8216_SUPPORT=y
# CONFIG_AG71XX_DEBUG is not set
# CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP81=y
CONFIG_AR71XX_MACH_AP83=y
CONFIG_AR71XX_MACH_AW_NR580=y
CONFIG_AR71XX_MACH_GENERIC=y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index e348c8852b..355a294e2b 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -6,6 +6,10 @@ config AR71XX_EARLY_SERIAL
menu "Atheros AR71xx machine selection"
+config AR71XX_MACH_AP81
+ bool "Atheros AP81 board support"
+ default y
+
config AR71XX_MACH_AP83
bool "Atheros AP83 board support"
default y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index 0d2b358204..64030540ec 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -10,6 +10,7 @@
obj-y := prom.o irq.o setup.o devices.o gpio.o ar71xx.o
+obj-$(CONFIG_AR71XX_MACH_AP81) += mach-ap81.o
obj-$(CONFIG_AR71XX_MACH_AP83) += mach-ap83.o
obj-$(CONFIG_AR71XX_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_AR71XX_MACH_GENERIC) += mach-generic.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c
new file mode 100644
index 0000000000..01504a7d9b
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c
@@ -0,0 +1,22 @@
+/*
+ * Atheros AP81 board support
+ *
+ * Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2009 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "devices.h"
+
+static void __init ap81_setup(void)
+{
+ ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_AP81, "Atheros AP81", ap81_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
index aa4da8e231..810b4747f1 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
@@ -45,12 +45,15 @@ static struct board_rec boards[] __initdata = {
.name = "493",
.mach_type = AR71XX_MACH_RB_493,
}, {
- .name = "AW-NR580",
- .mach_type = AR71XX_MACH_AW_NR580,
+ .name = "AP81",
+ .mach_type = AR71XX_MACH_AP81,
}, {
.name = "AP83",
.mach_type = AR71XX_MACH_AP83,
}, {
+ .name = "AW-NR580",
+ .mach_type = AR71XX_MACH_AW_NR580,
+ }, {
.name = "TEW-632BRP",
.mach_type = AR71XX_MACH_TEW_632BRP,
}, {
diff --git a/target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
index f6acb11991..52531ce0fb 100644
--- a/target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
@@ -129,6 +129,7 @@ extern unsigned long ar71xx_mach_type;
#define AR71XX_MACH_UBNT_LSSR71 15 /* Ubiquiti LS-SR71 */
#define AR71XX_MACH_TL_WR941ND 16 /* TP-LINK TL-WR941ND */
#define AR71XX_MACH_UBNT_RSPRO 17 /* Ubiquiti RouterStation Pro */
+#define AR71XX_MACH_AP81 18 /* Atheros AP81 */
/*
* PLL block