aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-24 23:45:28 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-24 23:45:28 +0000
commit7c5e0d227a7ec469fa26cb5950a852a22a8614d8 (patch)
tree17b91a2bc27050f310675924a213675a049f8b45 /target
parenta3cc68488818de0d968ae26504fd8eddb2da4aa2 (diff)
downloadmaster-187ad058-7c5e0d227a7ec469fa26cb5950a852a22a8614d8.tar.gz
master-187ad058-7c5e0d227a7ec469fa26cb5950a852a22a8614d8.tar.bz2
master-187ad058-7c5e0d227a7ec469fa26cb5950a852a22a8614d8.zip
add support for multiple target arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1543 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/linux-2.4/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index 8305f9c263..5b6c71df3d 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -188,7 +188,7 @@ $(LINUX_DIR)/.configured: $(LINUX_DIR)/.patched
-cp $(LINUX_KCONFIG) $(LINUX_DIR)/.config
$(SED) "s,^CROSS_COMPILE.*,CROSS_COMPILE=$(KERNEL_CROSS),g;" \
$(LINUX_DIR)/Makefile \
- $(LINUX_DIR)/arch/mips/Makefile
+ $(LINUX_DIR)/arch/*/Makefile
$(SED) "s,\-mcpu=,\-mtune=,g;" $(LINUX_DIR)/arch/mips/Makefile
$(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) oldconfig include/linux/version.h
touch $(LINUX_DIR)/.configured